summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-03-02 14:54:38 -0500
committerCarlos Aznarán Laos2022-03-02 14:54:38 -0500
commitac1adf15fce073866ce51187132bc913bf42eb53 (patch)
treec898c065bced2e78bccb762bf25702c838084ba7
parentd7f5b068232b2c56b5518b5b802d17e6fb3bdcdb (diff)
downloadaur-ac1adf15fce073866ce51187132bc913bf42eb53.tar.gz
Version bump to 0.7.3
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD43
3 files changed, 42 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 30922257488f..4e76a9643e1d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,21 @@
pkgbase = python-imread
- pkgdesc = mahotas-imread: A library to read & write to numpy arrays
- pkgver = 0.7.1
+ pkgdesc = Read images to numpy arrays
+ pkgver = 0.7.3
pkgrel = 1
- url = http://luispedro.org/software/imread/
+ url = https://github.com/luispedro/imread
arch = any
license = MIT
+ checkdepends = python-nose
makedepends = python-setuptools
- depends = python
- depends = libpng
- depends = libtiff
- depends = libwebp
+ makedepends = libpng
+ makedepends = libjpeg-turbo
+ makedepends = libtiff
+ makedepends = libwebp
+ makedepends = xcftools
+ makedepends = git
depends = python-numpy
- provides = python-imread
- source = https://pypi.python.org/packages/4e/7e/52603151a6746a229f80b3d22a08e468dce9bcf723728a3b99d050372e86/imread-0.7.1.tar.gz
- sha256sums = c343b546ab54acdb50dbe69d6793d64ead3ba6d585022f5a7ad4687b7f3db79b
+ source = git+https://github.com/luispedro/imread.git?signed#tag=v0.7.3
+ validpgpkeys = 6FB8B07A620CC7A7FB5B2AB4110D6C98E760BEF2
+ sha512sums = SKIP
pkgname = python-imread
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 16003b75dcd0..ab56fc0fcd40 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,35 @@
-# Maintainer: David McInnis <dave@dave3.xyz>
-# Maintainer: Jean Lucas <jean@4ray.co>
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: David McInnis <dave@dave3.xyz>
+# Contributor: Jean Lucas <jean@4ray.co>
# Contributor: McNoggins <gagnon88 at Gmail dot com>
-
-pkgname=python-imread
-pkgver=0.7.1
+_base=imread
+pkgname=python-${_base}
+pkgdesc="Read images to numpy arrays"
+pkgver=0.7.3
pkgrel=1
-pkgdesc='mahotas-imread: A library to read & write to numpy arrays'
arch=(any)
-url='http://luispedro.org/software/imread/'
+url="https://github.com/luispedro/${_base}"
license=(MIT)
-depends=(python libpng libtiff libwebp python-numpy)
-makedepends=(python-setuptools)
-provides=(python-imread)
-source=(https://pypi.python.org/packages/4e/7e/52603151a6746a229f80b3d22a08e468dce9bcf723728a3b99d050372e86/imread-$pkgver.tar.gz)
-sha256sums=(c343b546ab54acdb50dbe69d6793d64ead3ba6d585022f5a7ad4687b7f3db79b)
+depends=(python-numpy)
+makedepends=(python-setuptools libpng libjpeg-turbo libtiff libwebp xcftools git)
+checkdepends=(python-nose)
+source=("git+${url}.git?signed#tag=v${pkgver}")
+sha512sums=('SKIP')
+validpgpkeys=('6FB8B07A620CC7A7FB5B2AB4110D6C98E760BEF2') # Lu\xed\x73 Pedro Coelho <lpc@cmu.edu>
-package() {
- cd $srcdir/imread-$pkgver
- python setup.py install --root=$pkgdir --optimize=1
+build() {
+ cd ${_base}
+ export PYTHONHASHSEED=0
+ python setup.py build
+}
+
+check() {
+ cd ${_base}
+ python setup.py test
}
+package() {
+ cd ${_base}
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm 644 COPYING.MIT -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}