summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlll2yu2019-06-04 07:33:47 +0530
committerlll2yu2019-06-04 07:33:47 +0530
commit308a1c87db4b99150d5335b0a805bbfd118f7e8a (patch)
treef3ae94a73bfc05f627ae5f1fdc7533e18d388394
downloadaur-308a1c87db4b99150d5335b0a805bbfd118f7e8a.tar.gz
initial release
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD18
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..342117d7c8bc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-iniherit
+ pkgdesc = A ConfigParser subclass with file-specified inheritance.
+ pkgver = 0.3.9
+ pkgrel = 1
+ url = http://github.com/cadithealth/iniherit
+ arch = any
+ license = MIT
+ license = custom:Public Domain
+ makedepends = python-pip
+ makedepends = python-wheel
+ depends = python
+ depends = python-six
+ source = https://files.pythonhosted.org/packages/65/a5/5bb95059c92c23560a80bcd599bc737a4175b275b3a577cb19f66bd302e3/iniherit-0.3.9.tar.gz
+ sha256sums = 06d90849ff0c4fadb7e255ce31e7c8e188a99af90d761435c72b79b36adbb67a
+
+pkgname = python-iniherit
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8c8c9f132d80
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: lll2yu <lll2yu@protonmail.com>
+
+pkgname=python-iniherit
+pkgver=0.3.9
+pkgrel=1
+pkgdesc='A ConfigParser subclass with file-specified inheritance.'
+arch=(any)
+url=http://github.com/cadithealth/iniherit
+license=(MIT 'custom:Public Domain')
+depends=(python python-six)
+makedepends=(python-pip python-wheel)
+source=(https://files.pythonhosted.org/packages/65/a5/5bb95059c92c23560a80bcd599bc737a4175b275b3a577cb19f66bd302e3/iniherit-$pkgver.tar.gz)
+sha256sums=('06d90849ff0c4fadb7e255ce31e7c8e188a99af90d761435c72b79b36adbb67a')
+
+package() {
+ cd iniherit-$pkgver
+ python setup.py install -O1 --root="$pkgdir"
+}