summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSophie Tauchert2019-01-30 23:06:08 +0100
committerSophie Tauchert2019-01-30 23:06:08 +0100
commit3815f6691775d8d265081e3b0d8c19027a3906c8 (patch)
tree7a123c628866c25964541482a945b6efc183749b
downloadaur-3815f6691775d8d265081e3b0d8c19027a3906c8.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD25
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d9cd273fe148
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-injector
+ pkgdesc = Python dependency injection framework, inspired by Guice.
+ pkgver = 0.14.1
+ pkgrel = 1
+ url = http://github.com/alecthomas/injector
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ source = https://files.pythonhosted.org/packages/source/i/injector/injector-0.14.1.tar.gz
+ sha256sums = 1413e2b1dd90c594689bc292bcc02628b969840c1292131455927f292c65e99a
+
+pkgname = python-injector
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b97c6630745b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Sophie Tauchert <sophie@999eagle.moe>
+
+_pkgname=injector
+pkgname=python-${_pkgname}
+pkgver=0.14.1
+pkgrel=1
+pkgdesc="Python dependency injection framework, inspired by Guice."
+arch=('any')
+url="http://github.com/alecthomas/injector"
+license=('BSD')
+depends=()
+makedepends=('python-setuptools')
+provides=()
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('1413e2b1dd90c594689bc292bcc02628b969840c1292131455927f292c65e99a')
+
+build() {
+ cd "${_pkgname}-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "${_pkgname}-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}