summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSophie Tauchert2019-02-01 10:44:40 +0100
committerSophie Tauchert2019-02-01 10:44:40 +0100
commit65c3d02ca175bcafc7b4e75868a633a87badfa13 (patch)
tree180d1fdc2417744243ed119bb82a6cfcbc4d9aa7
parent3815f6691775d8d265081e3b0d8c19027a3906c8 (diff)
downloadaur-65c3d02ca175bcafc7b4e75868a633a87badfa13.tar.gz
Add LICENSE
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d9cd273fe148..35874d719937 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,16 @@
pkgbase = python-injector
pkgdesc = Python dependency injection framework, inspired by Guice.
pkgver = 0.14.1
- pkgrel = 1
+ pkgrel = 2
url = http://github.com/alecthomas/injector
arch = any
license = BSD
makedepends = python-setuptools
+ depends = python
source = https://files.pythonhosted.org/packages/source/i/injector/injector-0.14.1.tar.gz
+ source = https://raw.githubusercontent.com/alecthomas/injector/0.14.1/COPYING
sha256sums = 1413e2b1dd90c594689bc292bcc02628b969840c1292131455927f292c65e99a
+ sha256sums = 567278bc23fa55244f132af7164aa684940c75fa35b19c395899422cb92613ba
pkgname = python-injector
diff --git a/PKGBUILD b/PKGBUILD
index b97c6630745b..f2c946ddb2ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,18 @@
_pkgname=injector
pkgname=python-${_pkgname}
pkgver=0.14.1
-pkgrel=1
+pkgrel=2
pkgdesc="Python dependency injection framework, inspired by Guice."
arch=('any')
url="http://github.com/alecthomas/injector"
license=('BSD')
-depends=()
+depends=('python')
makedepends=('python-setuptools')
provides=()
-source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
-sha256sums=('1413e2b1dd90c594689bc292bcc02628b969840c1292131455927f292c65e99a')
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz"
+ "https://raw.githubusercontent.com/alecthomas/injector/${pkgver}/COPYING")
+sha256sums=('1413e2b1dd90c594689bc292bcc02628b969840c1292131455927f292c65e99a'
+ '567278bc23fa55244f132af7164aa684940c75fa35b19c395899422cb92613ba')
build() {
cd "${_pkgname}-$pkgver"
@@ -20,6 +22,7 @@ build() {
}
package() {
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
cd "${_pkgname}-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}