summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClaudia2023-03-26 20:50:16 +0200
committerClaudia2023-03-26 20:50:16 +0200
commit80d93df8c028f2cdfae7832b90291794a36db440 (patch)
tree71245bde96dc0d0fe533e20d503c74f727c00e23
parentae2ea53a099366565b0efbdec33248672c59350d (diff)
downloadaur-80d93df8c028f2cdfae7832b90291794a36db440.tar.gz
Remove mainlined patches, thanks user @Sinned
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
-rw-r--r--github-pr-8.patch27
-rw-r--r--github-pr-9.patch24
4 files changed, 2 insertions, 68 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9767938c5696..0787f3712de0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-ink-extensions-git
pkgdesc = Python dependencies for running Inkscape extensions outside of Inkscape
- pkgver = r20.6a246a5
+ pkgver = r27.8246f22
pkgrel = 1
url = https://github.com/evil-mad/ink_extensions
arch = any
@@ -16,10 +16,6 @@ pkgbase = python-ink-extensions-git
conflicts = python-ink-extensions
options = !strip
source = python-ink-extensions-git::git+https://github.com/evil-mad/ink_extensions.git
- source = github-pr-8.patch
- source = github-pr-9.patch
sha512sums = SKIP
- sha512sums = b1ce78e3e79631359f76476d67a515a2f7e68a08c78e36717a4a8c038fb8fd8adca7002611c26412f997cad66b96215af8587b8038644861ab872e61e3dc4089
- sha512sums = 10dc10a5fc741332b35479af26bbd4867015df2580e0530e4ff77cfcc9a8ebb36e2b4c7b3cb123a22eab6cb1af49b34f2b8f9e908037786b9294c152eff447fe
pkgname = python-ink-extensions-git
diff --git a/PKGBUILD b/PKGBUILD
index 0cf29f58db43..24df68b9723a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=python-ink-extensions-git
_gitpkgname=ink_extensions
-pkgver=r20.6a246a5
+pkgver=r27.8246f22
pkgrel=1
pkgdesc='Python dependencies for running Inkscape extensions outside of Inkscape'
arch=('any')
@@ -23,14 +23,10 @@ options=('!strip')
source=(
"${pkgname}::git+https://github.com/evil-mad/ink_extensions.git"
- 'github-pr-8.patch'
- 'github-pr-9.patch'
)
sha512sums=(
'SKIP'
- 'b1ce78e3e79631359f76476d67a515a2f7e68a08c78e36717a4a8c038fb8fd8adca7002611c26412f997cad66b96215af8587b8038644861ab872e61e3dc4089'
- '10dc10a5fc741332b35479af26bbd4867015df2580e0530e4ff77cfcc9a8ebb36e2b4c7b3cb123a22eab6cb1af49b34f2b8f9e908037786b9294c152eff447fe'
)
pkgver() {
@@ -39,13 +35,6 @@ pkgver() {
"$(git -C "${pkgname}" rev-parse --short HEAD)"
}
-prepare() {
- # https://github.com/evil-mad/ink_extensions/pull/8
- patch -p1 -d "${srcdir}/${pkgname}" < github-pr-8.patch
- # https://github.com/evil-mad/ink_extensions/pull/9
- patch -p1 -d "${srcdir}/${pkgname}" < github-pr-9.patch
-}
-
build() {
cd "${srcdir}/${pkgname}"
python -m build --wheel --no-isolation
diff --git a/github-pr-8.patch b/github-pr-8.patch
deleted file mode 100644
index 1fc8727bb347..000000000000
--- a/github-pr-8.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From a34351f3e2c7970b900b26aeed3eed61f89a71a4 Mon Sep 17 00:00:00 2001
-From: Claudia Pellegrino <claui@users.noreply.github.com>
-Date: Sun, 23 Oct 2022 17:38:03 +0200
-Subject: [PATCH] Fix `ValueError` in Python 3.8 or newer
-
-Validation has become stricter in Python 3.8.
-So we need to pass `validate=False` to the constructor in this one case,
-lest Python will print the following error message:
-
-> ValueError: Invalid format 'a really silly format that discards the actual message' for '%' style
----
- test/test_utils/test_message.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/test/test_utils/test_message.py b/test/test_utils/test_message.py
-index 60d052e..4c6cd58 100644
---- a/test/test_utils/test_message.py
-+++ b/test/test_utils/test_message.py
-@@ -23,7 +23,7 @@ def test_init(self, m_errormsg):
- def test_init_w_formatter(self, m_errormsg):
- logger = logging.getLogger('test_init_w_formatter')
- format_string = 'a really silly format that discards the actual message'
-- handler = message.UserMessageHandler(logging.Formatter(format_string))
-+ handler = message.UserMessageHandler(logging.Formatter(format_string, validate=False))
- logger.addHandler(handler)
-
- logger.info("WEEEOOOWEEEOOOWEEEOOO")
diff --git a/github-pr-9.patch b/github-pr-9.patch
deleted file mode 100644
index 3e9980bca6a3..000000000000
--- a/github-pr-9.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From 13bef6441fe483ae2f28a8668bd2d25291631a26 Mon Sep 17 00:00:00 2001
-From: Claudia Pellegrino <claui@users.noreply.github.com>
-Date: Sun, 23 Oct 2022 18:03:54 +0200
-Subject: [PATCH] Remove `test` modules from sdist, wheel
-
-I think the `test` modules are not supposed to be included in the sdist
-and wheels.
----
- setup.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/setup.py b/setup.py
-index 7d0856a..77cc03e 100644
---- a/setup.py
-+++ b/setup.py
-@@ -21,7 +21,7 @@
- long_description_content_type='text/markdown',
- url='https://github.com/evil-mad/ink_extensions',
-
-- packages=find_packages(exclude=['contrib', 'docs', 'tests']),
-+ packages=find_packages(exclude=['contrib', 'docs', 'test', 'test.*']),
- install_requires=[
- 'lxml'
- ],