summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrent s2019-05-24 07:35:36 -0400
committerbrent s2019-05-24 07:35:36 -0400
commit07713fefdcf91e860e4fcde0c8d7b371289a94de (patch)
tree2b767cda8cc8a2902fec8fac9a5ab5a17189b8e5
parent87ed3b43bfcf8b243534dcd7986598a8b0c24d11 (diff)
downloadaur-07713fefdcf91e860e4fcde0c8d7b371289a94de.tar.gz
whoops, depends on nose now. thanks, 1ace!
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD12
2 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 35b06120ac66..9fa1dfbabea5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,29 @@
-# Generated by mksrcinfo v8
-# Mon Dec 3 11:14:09 UTC 2018
pkgbase = python-inotify
pkgdesc = Access inotify events via python (this is NOT related to python-pynotify!)
pkgver = 0.2.10
- pkgrel = 2
+ pkgrel = 3
url = https://pypi.python.org/pypi/inotify
- arch = i686
- arch = x86_64
+ arch = any
license = GPL2
makedepends = python
makedepends = python-setuptools
makedepends = python2
makedepends = python2-setuptools
depends = python
+ depends = python-nose
depends = python2
+ depends = python2-nose
source = https://files.pythonhosted.org/packages/source/i/inotify/inotify-0.2.10.tar.gz
source = inotify-0.2.10.tar.gz.sig
+ validpgpkeys = 748231EBCBD808A14F5E85D28C004C2F93481F6B
sha512sums = d6ec9acbf4f2317cfe6b8caf9b00386bcaf2da0263089618f6856cc05ca9ec4358206cb88ab8fe363a6f81e69e3c175b13d670ef317ffb2de7b7ab5b00303d27
sha512sums = SKIP
pkgname = python-inotify
depends = python
+ depends = python-nose
pkgname = python2-inotify
depends = python2
+ depends = python2-nose
diff --git a/PKGBUILD b/PKGBUILD
index d42458bdaecb..c2fd3deaf2e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,12 @@ validpgpkeys=('748231EBCBD808A14F5E85D28C004C2F93481F6B')
# News updates for packages can be followed at https://devblog.square-r00t.net
pkgname=('python-inotify' 'python2-inotify')
pkgver=0.2.10
-pkgrel=2
+pkgrel=3
pkgdesc="Access inotify events via python (this is NOT related to python-pynotify!)"
-arch=( 'i686' 'x86_64' )
+arch=('any')
url="https://pypi.python.org/pypi/inotify"
-license=( 'GPL2' )
-depends=( 'python' 'python2' )
+license=('GPL2')
+depends=('python' 'python-nose' 'python2' 'python2-nose')
makedepends=('python' 'python-setuptools' 'python2' 'python2-setuptools')
_pkgname=inotify
install=
@@ -21,13 +21,13 @@ sha512sums=('d6ec9acbf4f2317cfe6b8caf9b00386bcaf2da0263089618f6856cc05ca9ec43582
'SKIP')
package_python-inotify() {
- depends=('python')
+ depends=('python' 'python-nose')
cd "${srcdir}/${_pkgname}-${pkgver}"
python3 setup.py install --root="${pkgdir}" --optimize=1
}
package_python2-inotify() {
- depends=('python2')
+ depends=('python2' 'python2-nose')
cd "${srcdir}/${_pkgname}-${pkgver}"
python2 setup.py install --root="${pkgdir}" --optimize=1
}