summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrent s.2017-08-20 00:31:06 -0400
committerbrent s.2017-08-20 00:31:06 -0400
commit13f6a2ce7296f9593b70157ccbac44dabf5c4277 (patch)
tree28ea60bbde56692d9dbfd2cc86031b193b2b7c52
downloadaur-13f6a2ce7296f9593b70157ccbac44dabf5c4277.tar.gz
initial commit; setting up .gitignores and skeleton PKGBUILD
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore18
-rw-r--r--PKGBUILD29
-rw-r--r--inotify-0.2.8.tar.gz.sig16
4 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2f85fe51ff47
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by aurpkgs
+# Sun Aug 20 04:31:06 UTC 2017
+pkgbase = python-inotify
+ pkgdesc = Access inotify events via python (this is NOT related to python-pynotify!)
+ pkgver = 0.2.8
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/inotify
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = python
+ depends = python2
+ source = https://pypi.python.org/packages/ab/3b/ad48cb45af4af32341fc6bf28497081a885d1e23777d2827f3c61d734f02/inotify-0.2.8.tar.gz
+ source = inotify-0.2.8.tar.gz.sig
+ sha512sums = 06f0df041cd5071a1e844f329fa3828a4082d6b2d530e118cafb4e4a19635a0502cc0cdcb2c108fcfa51cd7cc8f3e3e33292d11136b8f068df544a1addfcc54d
+ sha512sums = SKIP
+
+pkgname = python-inotify
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e16177da2907
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,18 @@
+*/
+.*.swp
+*.pkg.tar.xz
+src/
+pkg/
+*.tar
+*.tar.bz2
+*.tar.xz
+*.tar.gz
+*.tgz
+*.txz
+*.tbz
+*.tbz2
+*.zip
+*.run
+*.7z
+*.rar
+*.deb
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f0c9b01e9ecc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: brent s. <bts[at]square-r00t[dot]net>
+validpgpkeys=('748231EBCBD808A14F5E85D28C004C2F93481F6B')
+# Bug reports can be filed at https://bugs.square-r00t.net/index.php?project=3
+# News updates for packages can be followed at https://devblog.square-r00t.net
+pkgname=python-inotify
+pkgver=0.2.8
+pkgrel=1
+pkgdesc="Access inotify events via python (this is NOT related to python-pynotify!)"
+arch=( 'i686' 'x86_64' )
+url="https://pypi.python.org/pypi/inotify"
+license=( 'GPL2' )
+depends=( 'python' 'python2' )
+makedepends=( 'python' 'python2' )
+_pkgname=python-inotify
+install=
+changelog=
+noextract=()
+source=("https://pypi.python.org/packages/ab/3b/ad48cb45af4af32341fc6bf28497081a885d1e23777d2827f3c61d734f02/inotify-0.2.8.tar.gz"
+ "inotify-0.2.8.tar.gz.sig")
+sha512sums=('06f0df041cd5071a1e844f329fa3828a4082d6b2d530e118cafb4e4a19635a0502cc0cdcb2c108fcfa51cd7cc8f3e3e33292d11136b8f068df544a1addfcc54d'
+ 'SKIP')
+build() {
+ cd "${srcdir}/${_pkgname}/src"
+ make prefix=${pkgdir}/usr
+}
+package() {
+ install -D -m755 ${srcdir}/${_pkgname}/src/${_pkgname} ${pkgdir}/usr/bin/${_pkgname}
+ install -D -m644 ${srcdir}/${_pkgname}/docs/README.html.en ${pkgdir}/usr/share/doc/${_pkgname}/README.html
+}
diff --git a/inotify-0.2.8.tar.gz.sig b/inotify-0.2.8.tar.gz.sig
new file mode 100644
index 000000000000..4e2484dd26d5
--- /dev/null
+++ b/inotify-0.2.8.tar.gz.sig
@@ -0,0 +1,16 @@
+-----BEGIN PGP SIGNATURE-----
+
+iQIzBAABCgAdFiEEdIIx68vYCKFPXoXSjABML5NIH2sFAlmZEIAACgkQjABML5NI
+H2t7jw//SqLd7Okq1JnCzM+wLyrs6GCzetVelhhcWVTYummarfAv6UqLE8Ii9FiD
+GKDzEfVx3IkOWWmi6WcE/PZTwgfbavQuL2X8K9ILqQdB3RdEyLui337jLslPqfI6
+DETVfzGPUI5fcYDr8Ie3Ua5mqGk1Sh1PUUS0QsuKw29qYeSmbufo3pfvgMdGpVrt
+ly6LHPS7Y7gpz78h+DL9nUWAK7jsa1/XIbEB/pk9rn6PDIoG0OBpg6J+wAikIgiG
+VA6+vL75oqCBC52QWAPoE0U2fi6UJ7wBosN9ejlbrL+JlO+1Ss/RV89PszzaDhjn
+0IQ/kr+gbCKoOZm7wiMwPLAiBBa6Bs60kpEhjYsITtYMzUQvEFKaDdk/X/8Gl4v1
+SBfzGrAQQRn3qLZH+HnhF2RjGLbWG4BNKxIUwi5s7uPiLC4DWjplDwEdArXBTAWg
+H/g+STYWomkqx/uIfU4/UYAh4AOtJYBwJLoRpkzHErb/U/Set+fXvyi4Gx4DHFiS
+xCh+yBN/dPPhZ3dMARI6YLn/8xG7JYmXlukNimujnoMP6sPZeZ7IkcV9rRWeN/LE
+PdeP9r5ONsr4k2Y3S3Ms/7WqZ4/xwiojGRNRX7X24bW9Qau8DiUTRCRxnZOm5udo
+a0jMkkm7TOqchNUZW6NmGnSprHb6BP+ugcglEz/BaHG9FIUJB2M=
+=R9Wh
+-----END PGP SIGNATURE-----