summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcell Meszaros2022-06-28 22:50:47 +0200
committerMarcell Meszaros2022-06-28 22:51:52 +0200
commitd7fb046ad0f3317b0fc185f90b64cbadecf48c4c (patch)
treeac96634ff46505585eb464b0187c8f3bd8cd06e1
parentf8295f813e9fd16419f2230b0fc81b91e5151d2f (diff)
downloadaur-d7fb046ad0f3317b0fc185f90b64cbadecf48c4c.tar.gz
0.2.10-4: drop python2
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD39
2 files changed, 21 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9fa1dfbabea5..0d69f545389b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,29 +1,16 @@
pkgbase = python-inotify
- pkgdesc = Access inotify events via python (this is NOT related to python-pynotify!)
+ pkgdesc = Access inotify events via python (this is not related to python-pynotify)
pkgver = 0.2.10
- pkgrel = 3
- url = https://pypi.python.org/pypi/inotify
+ pkgrel = 4
+ url = https://pypi.org/project/inotify/0.2.10/
arch = any
license = GPL2
- makedepends = python
makedepends = python-setuptools
- makedepends = python2
- makedepends = python2-setuptools
depends = python
- depends = python-nose
- depends = python2
- depends = python2-nose
source = https://files.pythonhosted.org/packages/source/i/inotify/inotify-0.2.10.tar.gz
source = inotify-0.2.10.tar.gz.sig
validpgpkeys = 748231EBCBD808A14F5E85D28C004C2F93481F6B
- sha512sums = d6ec9acbf4f2317cfe6b8caf9b00386bcaf2da0263089618f6856cc05ca9ec4358206cb88ab8fe363a6f81e69e3c175b13d670ef317ffb2de7b7ab5b00303d27
- sha512sums = SKIP
+ sha256sums = 974a623a338482b62e16d4eb705fb863ed33ec178680fc3e96ccdf0df6c02a07
+ sha256sums = SKIP
pkgname = python-inotify
- depends = python
- depends = python-nose
-
-pkgname = python2-inotify
- depends = python2
- depends = python2-nose
-
diff --git a/PKGBUILD b/PKGBUILD
index 3513c63b4901..3f8149c5dd51 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,33 @@
-# Contributor: Marcell Meszaros < marcell.meszaros AT runbox.eu >
+# Maintainer: Marcell Meszaros < marcell.meszaros AT runbox.eu >
# Contributor: brent s. <bts[at]square-r00t[dot]net>
-pkgname=('python-inotify' 'python2-inotify')
-_pkgname='inotify'
+pkgname='python-inotify'
+_name="${pkgname#python-}"
pkgver=0.2.10
-pkgrel=3
-pkgdesc='Access inotify events via python (this is NOT related to python-pynotify!)'
+pkgrel=4
+pkgdesc='Access inotify events via python (this is not related to python-pynotify)'
arch=('any')
-url="https://pypi.python.org/pypi/${_pkgname}"
+url="https://pypi.org/project/${_name}/${pkgver}/"
license=('GPL2')
depends=(
'python'
- 'python-nose'
- 'python2'
- 'python2-nose'
)
makedepends=(
- 'python'
'python-setuptools'
- 'python2'
- 'python2-setuptools'
)
-source=("https://files.pythonhosted.org/packages/source/i/${_pkgname}/${_pkgname}-${pkgver}.tar.gz"
- "${_pkgname}-${pkgver}.tar.gz.sig")
-sha512sums=('d6ec9acbf4f2317cfe6b8caf9b00386bcaf2da0263089618f6856cc05ca9ec4358206cb88ab8fe363a6f81e69e3c175b13d670ef317ffb2de7b7ab5b00303d27'
+_tarname="${_name}-${pkgver}"
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_tarname}.tar.gz"
+ "${_name}-${pkgver}.tar.gz.sig")
+sha256sums=('974a623a338482b62e16d4eb705fb863ed33ec178680fc3e96ccdf0df6c02a07'
'SKIP')
validpgpkeys=('748231EBCBD808A14F5E85D28C004C2F93481F6B')
-package_python-inotify() {
- depends=('python' 'python-nose')
- cd "${srcdir}/${_pkgname}-${pkgver}"
- python3 setup.py install --root="${pkgdir}" --optimize=1
+build() {
+ cd "${_tarname}"
+ python setup.py build
}
-package_python2-inotify() {
- depends=('python2' 'python2-nose')
- cd "${srcdir}/${_pkgname}-${pkgver}"
- python2 setup.py install --root="${pkgdir}" --optimize=1
+package() {
+ cd "${_tarname}"
+ python setup.py install --prefix='/usr' --root="${pkgdir}" --optimize=1 --skip-build
}