summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcell Meszaros2022-06-28 21:48:45 +0200
committerMarcell Meszaros2022-06-28 21:49:16 +0200
commitf8295f813e9fd16419f2230b0fc81b91e5151d2f (patch)
tree7c51cb7f4de9b0beefcfead55f41dc360d13cbd8
parent07713fefdcf91e860e4fcde0c8d7b371289a94de (diff)
downloadaur-f8295f813e9fd16419f2230b0fc81b91e5151d2f.tar.gz
refactor: formatting; change .gitignore
-rw-r--r--.gitignore30
-rw-r--r--PKGBUILD43
2 files changed, 39 insertions, 34 deletions
diff --git a/.gitignore b/.gitignore
index e16177da2907..6696e5c62eee 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,18 +1,16 @@
-*/
-.*.swp
-*.pkg.tar.xz
-src/
-pkg/
+# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
*.tar
-*.tar.bz2
-*.tar.xz
-*.tar.gz
-*.tgz
-*.txz
-*.tbz
-*.tbz2
+*.tar.*
+*.rpm
+*.jar
+*.exe
+*.msi
*.zip
-*.run
-*.7z
-*.rar
-*.deb
+*.tgz
+*.log
+*.log.*
+
+*/
+*.orig
+*.bak
+*.backup
diff --git a/PKGBUILD b/PKGBUILD
index c2fd3deaf2e3..3513c63b4901 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,40 @@
-# Maintainer: brent s. <bts[at]square-r00t[dot]net>
-validpgpkeys=('748231EBCBD808A14F5E85D28C004C2F93481F6B')
-# Bug reports can be filed at https://bugs.square-r00t.net/index.php?project=3
-# News updates for packages can be followed at https://devblog.square-r00t.net
+# Contributor: Marcell Meszaros < marcell.meszaros AT runbox.eu >
+# Contributor: brent s. <bts[at]square-r00t[dot]net>
+
pkgname=('python-inotify' 'python2-inotify')
+_pkgname='inotify'
pkgver=0.2.10
pkgrel=3
-pkgdesc="Access inotify events via python (this is NOT related to python-pynotify!)"
+pkgdesc='Access inotify events via python (this is NOT related to python-pynotify!)'
arch=('any')
-url="https://pypi.python.org/pypi/inotify"
+url="https://pypi.python.org/pypi/${_pkgname}"
license=('GPL2')
-depends=('python' 'python-nose' 'python2' 'python2-nose')
-makedepends=('python' 'python-setuptools' 'python2' 'python2-setuptools')
-_pkgname=inotify
-install=
-changelog=
-noextract=()
+depends=(
+ 'python'
+ 'python-nose'
+ 'python2'
+ 'python2-nose'
+)
+makedepends=(
+ 'python'
+ 'python-setuptools'
+ 'python2'
+ 'python2-setuptools'
+)
source=("https://files.pythonhosted.org/packages/source/i/${_pkgname}/${_pkgname}-${pkgver}.tar.gz"
"${_pkgname}-${pkgver}.tar.gz.sig")
sha512sums=('d6ec9acbf4f2317cfe6b8caf9b00386bcaf2da0263089618f6856cc05ca9ec4358206cb88ab8fe363a6f81e69e3c175b13d670ef317ffb2de7b7ab5b00303d27'
'SKIP')
+validpgpkeys=('748231EBCBD808A14F5E85D28C004C2F93481F6B')
package_python-inotify() {
- depends=('python' 'python-nose')
- cd "${srcdir}/${_pkgname}-${pkgver}"
- python3 setup.py install --root="${pkgdir}" --optimize=1
+ depends=('python' 'python-nose')
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python3 setup.py install --root="${pkgdir}" --optimize=1
}
package_python2-inotify() {
- depends=('python2' 'python2-nose')
- cd "${srcdir}/${_pkgname}-${pkgver}"
- python2 setup.py install --root="${pkgdir}" --optimize=1
+ depends=('python2' 'python2-nose')
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1
}