summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLiam Timms2021-07-20 11:10:03 -0400
committerLiam Timms2021-07-20 11:10:03 -0400
commit94d33a78c48f232846da504bf12506f38441e007 (patch)
tree7241dbf065d194f0c66d141fa272426d5f05fd94
downloadaur-94d33a78c48f232846da504bf12506f38441e007.tar.gz
initialization
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD35
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..648c2887b5f0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = python-intensity-normalization
+ pkgdesc = normalize the intensities of various MR image modalities
+ pkgver = 1.4.5
+ pkgrel = 1
+ url = https://github.com/jcreinhold/intensity-normalization
+ arch = any
+ license = Apache
+ makedepends = python-setuptools
+ depends = python
+ depends = python-matplotlib
+ depends = python-nibabel
+ depends = python-numpy
+ depends = python-scikit-image
+ depends = python-scikit-fuzzy
+ depends = python-scikit-learn
+ depends = python-scipy
+ depends = python-statsmodels
+ depends = python-webcolors
+ source = intensity-normalization-1.4.5.tar.gz::https://github.com/jcreinhold/intensity-normalization//archive/refs/tags/v1.4.5.tar.gz
+ sha512sums = 2cacaeaad0912f0a9cdab35d319542723430503f642d4e4fcabef9156e7d1a200817b3c693bc755fd7d4ac025a65a982756a969e4576c3c96d3f40db890757a2
+
+pkgname = python-intensity-normalization
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4ebb423459fb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Thomas Roos <mail [at] thomasroos.nl>
+# Co-maintainer: Liam Timms <timms5000@gmail.com>
+# Contributor: wedjat <wedjat@protonmail.com>
+# Contributor: Masoud <mpoloton@gmail.com>
+
+pkgname=python-intensity-normalization
+_pkgname=intensity-normalization
+pkgver=1.4.5
+pkgrel=1
+pkgdesc='normalize the intensities of various MR image modalities'
+arch=('any')
+url='https://github.com/jcreinhold/intensity-normalization'
+license=('Apache')
+depends=('python' 'python-matplotlib' 'python-nibabel' 'python-numpy' 'python-scikit-image' 'python-scikit-fuzzy' 'python-scikit-learn' 'python-scipy' 'python-statsmodels' 'python-webcolors')
+# building documentation may not work properly, since authors tell to use sphinx <=1.5.6, because "Sphinx >= 1.6 breaks the math_dollar extension"
+makedepends=('python-setuptools')
+# checkdepends=('python-nose' 'python-mock')
+optdepends=()
+source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/jcreinhold/${_pkgname}//archive/refs/tags/v${pkgver}.tar.gz")
+sha512sums=('2cacaeaad0912f0a9cdab35d319542723430503f642d4e4fcabef9156e7d1a200817b3c693bc755fd7d4ac025a65a982756a969e4576c3c96d3f40db890757a2')
+
+build()
+{
+ cd "$srcdir/${_pkgname}-$pkgver"
+ python setup.py build
+}
+
+
+package()
+{
+ cd "$srcdir/${_pkgname}-$pkgver"
+ python setup.py install --skip-build --root="$pkgdir" --optimize=1
+ install -Dm644 COPYING -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+