summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortocic2018-05-28 12:47:56 +0300
committertocic2018-05-28 12:47:56 +0300
commit9a076d3d3ca822e70e9c3aa4d4687e73f4c3a7cc (patch)
treecfd77146d42733b2f94a068eecb804665e1786ed
parentc9ef78fb1feae5be819d1d1a001b54e4b9f55b37 (diff)
downloadaur-9a076d3d3ca822e70e9c3aa4d4687e73f4c3a7cc.tar.gz
0.8-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD21
2 files changed, 16 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 83891e5f6aef..b6c8452eef6f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
-# Generated by mksrcinfo v8
-# Tue Jan 26 06:27:55 UTC 2016
pkgbase = python-interruptingcow
- pkgver = 0.6
+ pkgver = 0.8
pkgrel = 1
- url = https://pypi.python.org/pypi/interruptingcow
+ url = https://bitbucket.org/evzijst/interruptingcow
arch = any
- license = CUSTOM
+ license = MIT
makedepends = python2-setuptools
makedepends = python-setuptools
- source = https://pypi.python.org/packages/source/i/interruptingcow/interruptingcow-0.6.tar.gz
- md5sums = f31b238e72ce40239dd2275ccb73945f
+ source = https://pypi.python.org/packages/source/i/interruptingcow/interruptingcow-0.8.tar.gz
+ md5sums = 78162ad4fd78e5bcd353abff110dc32f
pkgname = python-interruptingcow
pkgdesc = Python3 interruptingcow library
diff --git a/PKGBUILD b/PKGBUILD
index e312df96d883..2a518c08aac4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
-# Maintainer: mawcomw <mawcomw@gmail.com>
+# Maintainer: tocic <tocic at protonmail dot ch>
+# Contributor: mawcomw <mawcomw@gmail.com>
_pkgname=interruptingcow
pkgbase=python-${_pkgname}
pkgname=("python-${_pkgname}" "python2-${_pkgname}")
-pkgver=0.6
+pkgver=0.8
pkgrel=1
arch=('any')
-url="https://pypi.python.org/pypi/${_pkgname}"
-license=('CUSTOM')
+url="https://bitbucket.org/evzijst/interruptingcow"
+license=('MIT')
makedepends=('python2-setuptools' 'python-setuptools')
-source=("https://pypi.python.org/packages/source/i/${_pkgname}/${_pkgname}-0.6.tar.gz")
-md5sums=('f31b238e72ce40239dd2275ccb73945f')
+source=("https://pypi.python.org/packages/source/i/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+md5sums=('78162ad4fd78e5bcd353abff110dc32f')
prepare() {
cp -r ${_pkgname}-${pkgver} python2-${_pkgname}-${pkgver}
@@ -29,9 +30,9 @@ package_python-interruptingcow() {
pkgdesc="Python3 interruptingcow library"
cd ${_pkgname}-${pkgver}
- python setup.py install --root="${pkgdir}" --optimize=1
+ python setup.py install --skip-build --root="$pkgdir" --optimize=1
- install -Dm644 LICENSE.txt "${pkgdir}"/usr/share/licenses/$pkgname/LICENSE.txt
+ install -Dm644 ./LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
package_python2-interruptingcow() {
@@ -39,7 +40,7 @@ package_python2-interruptingcow() {
pkgdesc="Python2 interruptingcow library"
cd python2-${_pkgname}-${pkgver}
- python2 setup.py install --root="${pkgdir}" --optimize=1
+ python2 setup.py install --skip-build --root="$pkgdir" --optimize=1
- install -Dm644 LICENSE.txt "${pkgdir}"/usr/share/licenses/$pkgname/LICENSE.txt
+ install -Dm644 ./LICENSE.txt "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
}