summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiacomo Vercesi2019-12-01 13:42:10 +0100
committerGiacomo Vercesi2019-12-01 13:42:10 +0100
commitd0b1669554b22c80ccf1dc132f0a6fc30fc73dea (patch)
tree815724dc94f3df525f435370465669ba6ac9fc4f
parentf30575afeaca13c36437e776c88eca9213896c9d (diff)
downloadaur-d0b1669554b22c80ccf1dc132f0a6fc30fc73dea.tar.gz
Drop pip, user github tarball
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD12
2 files changed, 14 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 69babee2707a..2dc44e832271 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,7 +5,10 @@ pkgbase = python-iperf3
url = https://github.com/thiezn/iperf3-python
arch = any
license = GPL
- makedepends = python-pip
+ depends = python
+ depends = iperf3
+ source = https://github.com/thiezn/iperf3-python/archive/v0.1.11.tar.gz
+ sha1sums = 6768f369167ee509ce20416be28846fc829a50af
pkgname = python-iperf3
diff --git a/PKGBUILD b/PKGBUILD
index 436bbf46278a..7a69ba845f05 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,16 @@ pkgdesc="A python library to interface with the ipef3 command-line tool"
arch=('any')
url="https://github.com/thiezn/iperf3-python"
license=('GPL')
-makedepends=('python-pip')
+depends=('python' 'iperf3')
+source=("https://github.com/thiezn/iperf3-python/archive/v$pkgver.tar.gz")
+sha1sums=('6768f369167ee509ce20416be28846fc829a50af')
+
+build() {
+ cd $srcdir/iperf3-python-$pkgver
+ python setup.py build
+}
package() {
- PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps iperf3
+ cd $srcdir/iperf3-python-$pkgver
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}