summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorredfish2023-09-03 22:32:15 -0400
committerredfish2023-09-03 22:32:15 -0400
commit6e22b1f19de74592c2a2df708b99a2df8f8a748c (patch)
tree8438cce2948e10be471bf78532a6511bd4ddd8c3
parent364eb5d7d7935e9791aa20669ee5b0f7eff99e9a (diff)
downloadaur-6e22b1f19de74592c2a2df708b99a2df8f8a748c.tar.gz
dep: ipfs package was renamed to kubo
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 37a8f8c49af8..513968002f0f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = python-ipfshttpclient
pkgdesc = Python IPFS HTTP client library
pkgver = 0.7.0
- pkgrel = 2
+ pkgrel = 3
url = https://pypi.python.org/pypi/ipfshttpclient
arch = any
license = MIT
+ checkdepends = kubo>=0.4.23
checkdepends = python-pytest
checkdepends = python-pytest-cov
checkdepends = python-pytest-ordering
@@ -22,7 +23,6 @@ pkgbase = python-ipfshttpclient
depends = python-requests
depends = python-setuptools
depends = python-six
- optdepends = go-ipfs: IPFS daemon
conflicts = python-ipfsapi
source = https://pypi.io/packages/source/i/ipfshttpclient/ipfshttpclient-0.7.0.tar.gz
sha256sums = feb1033c14c3ac87ee81264176c5beefeaf386385804427160466117ccc43693
diff --git a/PKGBUILD b/PKGBUILD
index d02a3696e48f..f21b12f7d4c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=python-ipfshttpclient
_name=ipfshttpclient
pkgver=0.7.0
-pkgrel=2
+pkgrel=3
pkgdesc="Python IPFS HTTP client library"
arch=('any')
conflicts=("python-ipfsapi") # legacy name
@@ -16,13 +16,13 @@ depends=('python'
'python-setuptools'
'python-six'
)
-checkdepends=('python-pytest' 'python-pytest-cov' 'python-pytest-ordering'
+checkdepends=('kubo>=0.4.23'
+ 'python-pytest' 'python-pytest-cov' 'python-pytest-ordering'
'python-pytest-dependency'
'python-mock' 'python-pytest-mock'
'python-cid' 'python-pytest-cid'
'python-pytest-localserver' 'python-pluggy' 'python-py'
)
-optdepends=('go-ipfs: IPFS daemon') # an IPFS deamon is a checkdepend, but not required to be go-ipfs
source=("https://pypi.io/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
build() {