summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorredfish2019-08-31 19:46:29 -0400
committerredfish2019-08-31 19:46:29 -0400
commitca7cef71d60e67df97c8b2a72794f98d597b674d (patch)
treefb75bd647466eefa3f5e3defdf4229f296e05d33
parentc2aa38a82967d0fb19919590e9eefe84c57b6842 (diff)
downloadaur-ca7cef71d60e67df97c8b2a72794f98d597b674d.tar.gz
add python-six dep
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1fc2022cafc6..d89b61b13422 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -17,6 +17,7 @@ pkgbase = python-ipfshttpclient
depends = python-netaddr
depends = python-requests
depends = python-setuptools
+ depends = python-six
optdepends = go-ipfs: IPFS daemon
conflicts = python-ipfsapi
source = https://pypi.io/packages/source/i/ipfshttpclient/ipfshttpclient-0.4.12.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index fed79831340a..71dd921e3cd2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,9 +14,12 @@ depends=('python'
'python-netaddr'
'python-requests'
'python-setuptools'
+ 'python-six'
)
checkdepends=('python-pytest' 'python-pytest-cov' 'python-pytest-ordering' 'python-pytest-mock'
- 'python-pytest-localserver' 'python-pluggy' 'python-py')
+ 'python-pytest-localserver' 'python-pluggy' 'python-py'
+ #python-py-cid # appears to be optional
+ )
optdepends=('go-ipfs: IPFS daemon') # an IPFS deamon is a checkdepend, but not required to be go-ipfs
source=("https://pypi.io/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")