summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWu Zhenyu2023-06-26 21:19:59 +0800
committerWu Zhenyu2023-06-26 21:19:59 +0800
commit95e73453221bc5c9d343bb719d6c92393c5de9cb (patch)
treef426fa434d69a7770df3d592eed476b23d109e62
parentd0e897177e2566113b3eb503e18e85b7842f1d55 (diff)
downloadaur-95e73453221bc5c9d343bb719d6c92393c5de9cb.tar.gz
:bug: Fix ldconfig warning
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c36d70e7af53..b4032c18e8e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,19 @@
_pkgname=ipp
pkgname=python-$_pkgname
pkgver=2021.8.0
-pkgrel=1
+pkgrel=2
pkgdesc="IntelĀ® Integrated Performance Primitives"
arch=(x86_64)
url=https://www.intel.com/content/www/us/en/developer/tools/oneapi/ipp.html
makedepends=(python-installer)
license=(custom)
_py=py2.py3
-source=("https://files.pythonhosted.org/packages/$_py/${_pkgname::1}/$_pkgname/${_pkgname//-/_}-$pkgver-$_py-none-manylinux1_$arch.whl")
+source=("https://files.pythonhosted.org/packages/$_py/${_pkgname::1}/$_pkgname/${_pkgname//-/_}-$pkgver-$_py-none-manylinux1_${arch[0]}.whl")
sha256sums=('9cfa52dde8859a1d0858e47cb325e545639ff008a32bf76d79adbfe7916bb05a')
package() {
- cd "$srcdir" || return 1
python -m installer --destdir="$pkgdir" ./*.whl
+ # avoid ldconfig warning
+ cd "$pkgdir/usr/lib" || exit 1
+ find . -name '*.so.*.*' -exec sh -c 'x=${1#./}; so1=${x%.*}; so2=${so1%.*}; rm $so1 && ln -s $x $so1; rm $so2 && ln -s $x $so2' sh {} \;
}