summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Ellison2016-05-24 12:31:38 -0400
committerMatthew Ellison2016-05-24 12:31:38 -0400
commit8125d3a1a555e1b46f5badeeaef6443ecb55633a (patch)
treed671a54e413f76656221dcff33d769ce24dc4dbc
parenta6b5f1ef5e86053b94841add55b81ac59dd3fdf2 (diff)
downloadaur-8125d3a1a555e1b46f5badeeaef6443ecb55633a.tar.gz
python-iptables 0.11.0-1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD26
2 files changed, 20 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 64c602a8bb95..729f1f187e0c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-iptables
pkgdesc = Python bindings for iptables
- pkgver = 0.7.0
+ pkgver = 0.11.0
pkgrel = 1
url = https://github.com/ldx/python-iptables
arch = x86_64
@@ -8,9 +8,10 @@ pkgbase = python-iptables
license = Apache
makedepends = python-setuptools
depends = python
+ depends = iptables
options = !emptydirs
- source = https://pypi.python.org/packages/source/p/python-iptables/python-iptables-0.7.0.tar.gz
- md5sums = e1ee97f15f1c7e2a8545ff7e0213c714
+ source = https://files.pythonhosted.org/packages/source/p/python-iptables/python-iptables-0.11.0.tar.gz
+ sha256sums = 55bdd0d8e3d0b4c27e4d61bf6f21ada1e19146c0adf65e5093e254a126abcce9
pkgname = python-iptables
diff --git a/PKGBUILD b/PKGBUILD
index d2d2b9bf18de..74bd2c559abe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,30 @@
-# Maintainer: Ivan Cai <caizixian@users.noreply.github.com>
+# Maintainer: Matthew Ellison <matt+aur@arroyonetworks>
+# Contributor: Ivan Cai <caizixian@users.noreply.github.com>
+
pkgname=python-iptables
-pkgver=0.7.0
+pkgver=0.11.0
pkgrel=1
-pkgdesc="Python bindings for iptables"
+pkgdesc='Python bindings for iptables'
arch=('x86_64' 'i686')
-url="https://github.com/ldx/python-iptables"
+url='https://github.com/ldx/python-iptables'
license=('Apache')
groups=()
-depends=('python')
+depends=('python' 'iptables')
makedepends=('python-setuptools')
provides=()
conflicts=()
replaces=()
backup=()
options=(!emptydirs)
-source=("https://pypi.python.org/packages/source/p/python-iptables/python-iptables-0.7.0.tar.gz")
-md5sums=('e1ee97f15f1c7e2a8545ff7e0213c714')
+source=("https://files.pythonhosted.org/packages/source/${pkgname:0:1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('55bdd0d8e3d0b4c27e4d61bf6f21ada1e19146c0adf65e5093e254a126abcce9')
-package() {
- cd "$srcdir/$pkgname-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
+check() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py check
}
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}