summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2020-08-19 11:36:04 -0400
committerGuillaume Horel2020-08-19 11:36:04 -0400
commit476c5c90cee1a8ff9c2aec55ceeff69ac8071b94 (patch)
tree5fc64e77318695d054d2093593b7bd1ea3cb3c16
downloadaur-476c5c90cee1a8ff9c2aec55ceeff69ac8071b94.tar.gz
initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD20
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..339864e08ad7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-ipysheet
+ pkgdesc = Spreadsheet in the jupyter notebook
+ pkgver = 0.4.4
+ pkgrel = 1
+ url = https://github.com/QuantStack/ipysheet
+ arch = any
+ license = MIT
+ depends = python-six
+ depends = python-ipywidgets
+ optdepends = python-pandas
+ options = !emptydirs
+ source = python-ipysheet-0.4.4.tar.gz::https://pypi.org/packages/source/i/ipysheet/ipysheet-0.4.4.tar.gz
+ sha256sums = 54e9dffb4384db8586d3ca6be6fd5679157f6cf98ecc9ad368fa938f889e58b2
+
+pkgname = python-ipysheet
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..602a6a448c1e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
+pkgname=python-ipysheet
+_pkgname=ipysheet
+pkgver=0.4.4
+pkgrel=1
+pkgdesc="Spreadsheet in the jupyter notebook"
+arch=('any')
+url="https://github.com/QuantStack/ipysheet"
+license=('MIT')
+checkdepends=()
+depends=('python-six' 'python-ipywidgets')
+optdepends=('python-pandas')
+options=(!emptydirs)
+source=("$pkgname-$pkgver.tar.gz::https://pypi.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
+sha256sums=('54e9dffb4384db8586d3ca6be6fd5679157f6cf98ecc9ad368fa938f889e58b2')
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}