summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Kotta2015-07-13 16:21:12 -0500
committerJonathan Kotta2015-07-13 16:21:12 -0500
commite9e67cc9aaf70be0f83062cce245c157e4f5639d (patch)
tree0e2928b1affff0837224c6f04f07fba105956d76
downloadaur-e9e67cc9aaf70be0f83062cce245c157e4f5639d.tar.gz
initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD28
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e4afc44f1347
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = python-ipython-sql
+ pkgdesc = Issue SQL commands from IPython.
+ pkgver = 0.3.4
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/ipython-sql
+ arch = any
+ license = custom:PYTHON
+ depends = ipython
+ depends = python-sqlalchemy
+ depends = python-prettytable
+ depends = python-sqlparse
+ source = https://pypi.python.org/packages/source/i/ipython-sql/ipython-sql-0.3.4.tar.gz
+ md5sums = a68076f11ae62197a16ed4000dcbe8d3
+
+pkgname = python-ipython-sql
+
+pkgname = python2-ipython-sql
+ depends = ipython2
+ depends = python2-sqlalchemy
+ depends = python2-prettytable
+ depends = python2-sqlparse
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c84f13bf6728
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Jonathan Kotta <jpkotta at gmail dot com>
+
+pkgbase=python-ipython-sql
+pkgname=(python-ipython-sql python2-ipython-sql)
+pkgver=0.3.4
+pkgrel=1
+pkgdesc="Issue SQL commands from IPython."
+arch=('any')
+url="https://pypi.python.org/pypi/ipython-sql"
+license=('custom:PYTHON')
+depends=('ipython' 'python-sqlalchemy' 'python-prettytable' 'python-sqlparse')
+source=(https://pypi.python.org/packages/source/i/ipython-sql/ipython-sql-$pkgver.tar.gz)
+md5sums=('a68076f11ae62197a16ed4000dcbe8d3')
+
+_package() {
+ _python=$1
+ cd $srcdir/ipython-sql-$pkgver
+ $_python setup.py install --root="$pkgdir"
+}
+
+package_python-ipython-sql() {
+ _package python
+}
+
+package_python2-ipython-sql() {
+ depends=($(echo ${depends[*]} | sed s/python/python2/g))
+ _package python2
+}