summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Botting2017-04-12 16:53:40 +1000
committerAndy Botting2017-04-12 16:53:40 +1000
commit02cc34c7170db1901c45140b4286b7de0caa0b42 (patch)
tree0b490de7d23c26e2496223767ca7d41915257f8c
parenta1a06cc15c3f687c826c565ad003cbe9f5b8a06e (diff)
downloadaur-02cc34c7170db1901c45140b4286b7de0caa0b42.tar.gz
Update to v1.12.0-2
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD32
2 files changed, 20 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4cec5cca0e01..0ad4580f5fc6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = python-ironicclient
pkgdesc = Python client library for Ironic
pkgver = 1.12.0
- pkgrel = 1
- url = http://docs.openstack.org/developer/python-ironicclient
+ pkgrel = 2
+ url = https://docs.openstack.org/developer/python-ironicclient/
arch = any
license = Apache
+ makedepends = git
makedepends = python-setuptools
makedepends = python2-setuptools
source = git+https://git.openstack.org/openstack/python-ironicclient#tag=1.12.0
diff --git a/PKGBUILD b/PKGBUILD
index c75064069914..6173985eecbe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,41 +2,43 @@
pkgname=('python-ironicclient' 'python2-ironicclient')
pkgver='1.12.0'
-pkgrel='1'
+pkgrel='2'
pkgdesc='Python client library for Ironic'
arch=('any')
-url='http://docs.openstack.org/developer/python-ironicclient'
+url="https://docs.openstack.org/developer/${pkgname}/"
license=('Apache')
-makedepends=('python-setuptools' 'python2-setuptools')
-source=("git+https://git.openstack.org/openstack/python-ironicclient#tag=$pkgver")
+makedepends=('git' 'python-setuptools' 'python2-setuptools')
+source=("git+https://git.openstack.org/openstack/${pkgname}#tag=${pkgver}")
md5sums=('SKIP')
prepare() {
- cp -a python-ironicclient{,-py2}
+ cp -a "${srcdir}/${pkgname}"{,-py2}
}
build() {
- cd "$srcdir"/python-ironicclient
+ cd "${srcdir}/${pkgname}"
python setup.py build
- cd "$srcdir"/python-ironicclient-py2
+ cd "${srcdir}/${pkgname}-py2"
python2 setup.py build
}
package_python-ironicclient() {
- depends=('python-six' 'python-requests' 'python-yaml' 'python-openstackclient'
- 'python-prettytable' 'python-oslo-utils' 'python-oslo-serialization'
- 'python-oslo-i18n' 'python-osc-lib' 'python-keystoneauth1'
- 'python-jsonschema' 'python-dogpile.cache' 'python-appdirs' 'python-pbr')
+ depends=('python-six' 'python-requests' 'python-yaml'
+ 'python-openstackclient' 'python-prettytable' 'python-oslo-utils'
+ 'python-oslo-serialization' 'python-oslo-i18n' 'python-osc-lib'
+ 'python-keystoneauth1' 'python-jsonschema' 'python-dogpile.cache'
+ 'python-appdirs' 'python-pbr')
cd "${srcdir}/${pkgname}"
python setup.py install --root="${pkgdir}" --optimize=1
}
package_python2-ironicclient() {
- depends=('python2-six' 'python2-requests' 'python2-yaml' 'python2-openstackclient'
- 'python2-prettytable' 'python2-oslo-utils' 'python2-oslo-serialization'
- 'python2-oslo-i18n' 'python2-osc-lib' 'python2-keystoneauth1'
- 'python2-jsonschema' 'python2-dogpile.cache' 'python2-appdirs' 'python2-pbr')
+ depends=('python2-six' 'python2-requests' 'python2-yaml'
+ 'python2-openstackclient' 'python2-prettytable' 'python2-oslo-utils'
+ 'python2-oslo-serialization' 'python2-oslo-i18n' 'python2-osc-lib'
+ 'python2-keystoneauth1' 'python2-jsonschema' 'python2-dogpile.cache'
+ 'python2-appdirs' 'python2-pbr')
cd "${srcdir}/python-ironicclient-py2"
python2 setup.py install --root="${pkgdir}" --optimize=1
mv "${pkgdir}"/usr/bin/ironic{,2}