summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGroctel2021-10-02 11:44:33 +0200
committerGroctel2021-10-02 11:44:33 +0200
commit695b96423afd33fbe34c15b1145450974dbc96a1 (patch)
treedbe7508dee49e66bef5b159b92ceaa7832ff2b0f
downloadaur-695b96423afd33fbe34c15b1145450974dbc96a1.tar.gz
First commit: v0.1.0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD34
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..081fe5150fcb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-isosurfaces
+ pkgdesc = Construct isolines/isosurfaces of a 2D/3D scalar field defined by a function.
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/jared-hughes/isosurfaces
+ arch = any
+ makedepends = python-setuptools
+ depends = python
+ depends = python-numpy
+ source = https://github.com/jared-hughes/isosurfaces/archive/refs/tags/v0.1.0.tar.gz
+ sha512sums = 0331d626dae0f1fd71ce9d9a559aa27d223ebf58c04564dd98b747cb81e6ee259696495c6deb7c6b47cd812647b505c3101486ee704bd9b69656396a6aac23a5
+
+pkgname = python-isosurfaces
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c2ed9ee823f6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Groctel <aur@taxorubio.com>
+
+_name=isosurfaces
+
+pkgname=python-isosurfaces
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Construct isolines/isosurfaces of a 2D/3D scalar field defined by a function."
+
+arch=('any')
+# license=('MIT') Missing in v0.1.0
+url="https://github.com/jared-hughes/isosurfaces"
+
+source=("$url/archive/refs/tags/v$pkgver.tar.gz")
+sha512sums=('0331d626dae0f1fd71ce9d9a559aa27d223ebf58c04564dd98b747cb81e6ee259696495c6deb7c6b47cd812647b505c3101486ee704bd9b69656396a6aac23a5')
+
+depends=(
+ 'python'
+ 'python-numpy'
+)
+makedepends=('python-setuptools')
+
+build ()
+{
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py build
+}
+
+package ()
+{
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1 --skip-build
+ # install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$_name/LICENSE"
+}