summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgroctel2023-11-26 10:38:48 +0100
committergroctel2023-11-26 10:38:48 +0100
commit874f8419d875ebcc2b4b77a250acc7d3694b9ced (patch)
tree8a8f4d5c3d73d90840a279105461072199bd0473
parent695b96423afd33fbe34c15b1145450974dbc96a1 (diff)
downloadaur-874f8419d875ebcc2b4b77a250acc7d3694b9ced.tar.gz
Updated installation method to follow PEP 517
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD32
2 files changed, 22 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 081fe5150fcb..5eb6019be4f3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,7 +4,11 @@ pkgbase = python-isosurfaces
pkgrel = 1
url = https://github.com/jared-hughes/isosurfaces
arch = any
+ license = MIT
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
+ makedepends = python-wheel
depends = python
depends = python-numpy
source = https://github.com/jared-hughes/isosurfaces/archive/refs/tags/v0.1.0.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index c2ed9ee823f6..ffc8a46a5687 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,28 +7,32 @@ pkgver=0.1.0
pkgrel=1
pkgdesc="Construct isolines/isosurfaces of a 2D/3D scalar field defined by a function."
-arch=('any')
-# license=('MIT') Missing in v0.1.0
+arch=("any")
+license=("MIT")
url="https://github.com/jared-hughes/isosurfaces"
source=("$url/archive/refs/tags/v$pkgver.tar.gz")
sha512sums=('0331d626dae0f1fd71ce9d9a559aa27d223ebf58c04564dd98b747cb81e6ee259696495c6deb7c6b47cd812647b505c3101486ee704bd9b69656396a6aac23a5')
depends=(
- 'python'
- 'python-numpy'
+ "python"
+ "python-numpy"
+)
+makedepends=(
+ "python-build"
+ "python-installer"
+ "python-setuptools"
+ "python-wheel"
)
-makedepends=('python-setuptools')
-build ()
-{
- cd "$srcdir/$_name-$pkgver"
- python setup.py build
+build () {
+ cd "$srcdir/$_name-$pkgver" || exit
+ python -m build --wheel --no-isolation
}
-package ()
-{
- cd "$srcdir/$_name-$pkgver"
- python setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1 --skip-build
- # install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$_name/LICENSE"
+package () {
+ cd "$srcdir/$_name-$pkgver" || exit
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ # LICENSE file missing in v0.1.0 package
+ # install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$_name/LICENSE"
}