summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTaiko2k2020-08-25 13:15:27 +1200
committerTaiko2k2020-08-25 13:16:58 +1200
commit937c9c860f35c44e729e7cc8298cd23f0b28ac94 (patch)
treef7c91248f3894bcba2d631694cdc80733df3418f
downloadaur-937c9c860f35c44e729e7cc8298cd23f0b28ac94.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a57290c572cc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-isounidecode
+ pkgdesc = Conversion and transliteration of unicode into ascii or iso-8859-1
+ pkgver = 0.3
+ pkgrel = 1
+ url = https://github.com/redvasily/isounidecode
+ arch = any
+ license = BSD 3-Clause
+ makedepends = python-setuptools
+ depends = python
+ source = https://pypi.org/packages/source/i/isounidecode/isounidecode-0.3.tar.gz
+ sha256sums = 4db0a962c6341826c9a69acaabc2f923a5b124d53a335be892ef29173bc31c5b
+
+pkgname = python-isounidecode
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..89379966c0e6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Taiko2k <captain dot gxj at gmail dot com>
+
+pkgname=python-isounidecode
+_name=${pkgname#python-}
+pkgver=0.3
+pkgrel=1
+pkgdesc="Conversion and transliteration of unicode into ascii or iso-8859-1"
+arch=('any')
+url="https://github.com/redvasily/isounidecode"
+license=('BSD 3-Clause')
+depends=('python')
+makedepends=('python-setuptools')
+source=("https://pypi.org/packages/source/${_name:0:1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('4db0a962c6341826c9a69acaabc2f923a5b124d53a335be892ef29173bc31c5b')
+
+build() {
+ cd "$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}
+