summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrej Radović2023-02-18 20:48:01 +0100
committerAndrej Radović2023-02-18 20:48:01 +0100
commitdb4faf52545eb4b11e7a60e4ac5c1eb709feed9a (patch)
treee4fddc1bb8495ac204ba9b55e22025714b7adb37
downloadaur-db4faf52545eb4b11e7a60e4ac5c1eb709feed9a.tar.gz
Initial release.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..18f14df5984d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-iteration-utilities
+ pkgdesc = Utilities based on Pythons iterators and generators.
+ pkgver = 0.11.0
+ pkgrel = 1
+ url = https://github.com/MSeifert04/iteration_utilities
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ optdepends = python-pytest
+ optdepends = python-sphinx
+ optdepends = python-numpydoc
+ source = https://files.pythonhosted.org/packages/source/i/iteration_utilities/iteration_utilities-0.11.0.tar.gz
+ sha256sums = f91f41a2549e9a7e40ff5460fdf9033b6ee5b305d9be77943b63a554534c2a77
+
+pkgname = python-iteration-utilities
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5ff3d8294ba8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Andrej Radović <r.andrej@gmail.com>
+pkgname=python-iteration-utilities
+_name=${pkgname#python-}
+pkgver=0.11.0
+pkgrel=1
+pkgdesc="Utilities based on Pythons iterators and generators."
+url="https://github.com/MSeifert04/iteration_utilities"
+depends=('python')
+makedepends=('python-setuptools')
+optdepends=(
+ 'python-pytest'
+ 'python-sphinx'
+ 'python-numpydoc'
+)
+license=('MIT')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name//-/_}/${_name//-/_}-$pkgver.tar.gz")
+sha256sums=('f91f41a2549e9a7e40ff5460fdf9033b6ee5b305d9be77943b63a554534c2a77')
+
+build() {
+ cd "$srcdir/${_name//-/_}-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/${_name//-/_}-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}