summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartino Pilia2018-03-27 08:31:16 +0200
committerMartino Pilia2018-03-27 08:31:16 +0200
commita71c0d4846a29f4399db551e02000801f869f21d (patch)
treefa18649ceffb5ffdbc58b35d0fb6b8a73262b53e
downloadaur-a71c0d4846a29f4399db551e02000801f869f21d.tar.gz
submit package (version 4.13.0)
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD39
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2255e82574d6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = python-itk
+ pkgdesc = ITK is an open-source toolkit for multidimensional image analysis
+ pkgver = 4.13.0
+ pkgrel = 1
+ url = https://itk.org/
+ arch = x86_64
+ license = apache
+ makedepends = python-pip
+ depends = python-numpy
+ options = !strip
+ source = https://files.pythonhosted.org/packages/cp36/i/itk/itk-4.13.0-cp36-cp36m-manylinux1_x86_64.whl
+ source = https://files.pythonhosted.org/packages/cp36/i/itk-segmentation/itk_segmentation-4.13.0-cp36-cp36m-manylinux1_x86_64.whl
+ source = https://files.pythonhosted.org/packages/cp36/i/itk-io/itk_io-4.13.0-cp36-cp36m-manylinux1_x86_64.whl
+ source = https://files.pythonhosted.org/packages/cp36/i/itk-registration/itk_registration-4.13.0-cp36-cp36m-manylinux1_x86_64.whl
+ source = https://files.pythonhosted.org/packages/cp36/i/itk-core/itk_core-4.13.0-cp36-cp36m-manylinux1_x86_64.whl
+ source = https://files.pythonhosted.org/packages/cp36/i/itk-numerics/itk_numerics-4.13.0-cp36-cp36m-manylinux1_x86_64.whl
+ source = https://files.pythonhosted.org/packages/cp36/i/itk-filtering/itk_filtering-4.13.0-cp36-cp36m-manylinux1_x86_64.whl
+ md5sums = 180434248774211ac5043128fee8cee1
+ md5sums = 3db37ab06ceb902f53947bbbfbedc4f1
+ md5sums = ae569328ce51f522d2d6722e8762601f
+ md5sums = 717c5d6f218716c3f20cf7a029077a7e
+ md5sums = bfdfd8d37b066bdbdc8b3d0f61aa0e22
+ md5sums = da955cbd76229f891f1a678e149d47a2
+ md5sums = 927919dd02c23dd86266576c238aaed0
+
+pkgname = python-itk
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d3773e106438
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer of this PKBGUILD file: Martino Pilia <martino.pilia@gmail.com>
+_components='itk itk-segmentation itk-io itk-registration itk-core itk-numerics itk-filtering'
+_py=cp36
+pkgname=python-itk
+pkgver=4.13.0
+pkgrel=1
+pkgdesc='ITK is an open-source toolkit for multidimensional image analysis'
+arch=('x86_64')
+url='https://itk.org/'
+license=('apache')
+depends=('python-numpy')
+makedepends=('python-pip')
+options=('!strip')
+optdepends=()
+source=()
+md5sums=('180434248774211ac5043128fee8cee1'
+ '3db37ab06ceb902f53947bbbfbedc4f1'
+ 'ae569328ce51f522d2d6722e8762601f'
+ '717c5d6f218716c3f20cf7a029077a7e'
+ 'bfdfd8d37b066bdbdc8b3d0f61aa0e22'
+ 'da955cbd76229f891f1a678e149d47a2'
+ '927919dd02c23dd86266576c238aaed0')
+
+for _name in $_components; do
+ source+=("https://files.pythonhosted.org/packages/$_py/${_name::1}/$_name/${_name/-/_}-$pkgver-$_py-${_py}m-manylinux1_x86_64.whl")
+done
+
+
+package() {
+
+ # NOTE
+ # The official Python wheel does not wrap all image types.
+ # To have them, ITK must be built from source using the
+ # package insight-toolkit, enabling Python wrapping and
+ # additional components to be wrapped in the CMake config.
+
+ PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps *.whl
+}
+