summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartino Pilia2021-04-04 17:17:40 +0200
committerMartino Pilia2021-04-04 17:18:23 +0200
commit291a79ea9678874fce58071e70e52b99a1c8bf4d (patch)
tree7c343a05ed6997243d33b348d34152272af9de6e
downloadaur-291a79ea9678874fce58071e70e52b99a1c8bf4d.tar.gz
Package submission
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..513420c081fb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-itk-bin
+ pkgdesc = Open-source toolkit for multidimensional image analysis
+ pkgver = 5.2.0
+ pkgrel = 1
+ url = https://itk.org/
+ arch = x86_64
+ license = Apache
+ makedepends = python-pip
+ depends = python-numpy
+ provides = python-itk
+ conflicts = python-itk
+ noextract = itk-5.2.0-cp39-cp39-manylinux2014_x86_64.whl
+ source = https://files.pythonhosted.org/packages/cp39/i/itk/itk-5.2.0-cp39-cp39-manylinux2014_x86_64.whl
+ sha256sums = 3f5c92ea9c11d138a203cdd2e113d638a673610e0b0f4e48a74439788b1eb268
+
+pkgname = python-itk-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ad3f088598c2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer of this PKBGUILD file: Martino Pilia <martino.pilia@gmail.com>
+_name=itk
+_python_version=$(python -c "import sys; print(f'{sys.version_info.major}.{sys.version_info.minor}')")
+_py="cp${_python_version//./}"
+pkgname=python-itk-bin
+pkgver=5.2.0
+pkgrel=1
+pkgdesc="Open-source toolkit for multidimensional image analysis"
+arch=('x86_64')
+url='https://itk.org/'
+license=('Apache')
+depends=('python-numpy')
+provides=('python-itk')
+conflicts=('python-itk')
+makedepends=('python-pip')
+_wheel="$_name-$pkgver-${_py}-${_py}-manylinux2014_x86_64.whl"
+noextract=("${_wheel}")
+source=("https://files.pythonhosted.org/packages/$_py/${_name::1}/${_name}/${_wheel}")
+sha256sums=('3f5c92ea9c11d138a203cdd2e113d638a673610e0b0f4e48a74439788b1eb268')
+
+package() {
+ cd "$srcdir"
+
+ PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps ./*.whl
+ python -O -m compileall "${pkgdir}/usr/lib/python${_python_version}/site-packages/ITK"
+}
+