summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Forencich2015-07-20 12:17:57 -0700
committerAlex Forencich2015-07-20 12:17:57 -0700
commit185ffb870ea922358fe5c76ffeb7a2213fa20a94 (patch)
treed201cbc0790ed12422a8244178ec64bd1da52e85
downloadaur-185ffb870ea922358fe5c76ffeb7a2213fa20a94.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD37
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e720dab337e8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-ivi-git
+ pkgdesc = Python Interchangeable Virtual Instrument Library
+ pkgver = 0.14.9.r0.g7edbd63
+ pkgrel = 1
+ url = https://github.com/python-ivi/python-ivi
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = python
+ depends = python-numpy
+ optdepends = python-vxi11: VXI11 instrument support
+ optdepends = python-usbtmc: USBTMC instrument support
+ optdepends = python-pyvisa: PyVISA interface for NI drivers
+ provides = python-ivi
+ source = python-ivi::git+https://github.com/python-ivi/python-ivi.git
+ md5sums = SKIP
+
+pkgname = python-ivi-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b193564116bb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Alex Forencich <alex@alexforencich.com>
+pkgname=python-ivi-git
+pkgver=0.14.9.r0.g7edbd63
+pkgrel=1
+pkgdesc="Python Interchangeable Virtual Instrument Library"
+arch=('any')
+url="https://github.com/python-ivi/python-ivi"
+license=('MIT')
+depends=('python' 'python-numpy')
+makedepends=('git')
+provides=('python-ivi')
+optdepends=(
+ 'python-vxi11: VXI11 instrument support'
+ 'python-usbtmc: USBTMC instrument support'
+ 'python-pyvisa: PyVISA interface for NI drivers'
+)
+
+_gitroot='https://github.com/python-ivi/python-ivi.git'
+_gitname='python-ivi'
+
+source=("$_gitname::git+$_gitroot")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ git describe --tags --long | sed -E 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/$_gitname"
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ python setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1
+}
+