summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMithicSpirit2023-03-09 11:22:06 -0500
committerMithicSpirit2023-03-09 11:22:06 -0500
commitb5d9f33393325fe8d3038ac89c75a598ff573eda (patch)
tree5016ea56f6003ce1f46e929c159321059e446637
downloadaur-b5d9f33393325fe8d3038ac89c75a598ff573eda.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD34
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c48ca2187c0d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-ixia
+ pkgdesc = A library connecting secrets' security with random's versatility
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://github.com/trag1c/ixia
+ arch = any
+ license = MIT
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-poetry-core
+ depends = python>=3.8
+ source = ixia-1.1.0.tar.gz::https://files.pythonhosted.org/packages/source/i/ixia/ixia-1.1.0.tar.gz
+ sha512sums = dfc5b801b1ea61df4d992dc73b637f20aad737506f6fcaa89e59a8ba8ce9fbc39230e485ae40c9d265be422b4dbde6f03ace997e2485947c6dbb44c9f93d8a52
+
+pkgname = python-ixia
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..167d5c3bc3e7
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/*
+
+!/.gitignore
+!/PKGBUILD
+!/.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4678597cf395
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: MithicSpirit <rpc01234 at gmail dot com>
+
+_pkgname=ixia
+pkgname="python-$_pkgname"
+pkgver=1.1.0
+pkgrel=1
+epoch=
+pkgdesc="A library connecting secrets' security with random's versatility"
+arch=(any)
+url="https://github.com/trag1c/$_pkgname"
+license=('MIT')
+depends=('python>=3.8')
+makedepends=('python-build' 'python-installer' 'python-poetry-core')
+checkdepends=()
+optdepends=()
+source=("$_pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
+sha512sums=('dfc5b801b1ea61df4d992dc73b637f20aad737506f6fcaa89e59a8ba8ce9fbc39230e485ae40c9d265be422b4dbde6f03ace997e2485947c6dbb44c9f93d8a52')
+
+build() {
+ cd ..
+ [ -f .gitignore ] && mv .gitignore .gitignore.tmp
+
+ pushd "$srcdir/$_pkgname-$pkgver"
+ python -m build --wheel --no-isolation
+
+ popd
+ [ -f .gitignore.tmp ] && mv .gitignore.tmp .gitignore || true
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}