summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBao Trinh2023-05-25 15:19:15 -0500
committerBao Trinh2023-05-25 15:31:07 -0500
commited17cc2ce0e6981202839767cab61bdd3a36f900 (patch)
tree22452c8d44e362c0de820644feff351a97719cfc
parentebf20ca5a56f89694b82233b8c8fa8d41ee3930a (diff)
downloadaur-ed17cc2ce0e6981202839767cab61bdd3a36f900.tar.gz
Fix for newer versions of python-scikit-build
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD15
-rw-r--r--scikit-build.patch12
4 files changed, 27 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a9c9807e652..cccf83f840a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-jarowinkler
pkgdesc = A library for fast approximate string matching using Jaro and Jaro-Winkler similarity
pkgver = 1.2.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/maxbachmann/JaroWinkler
arch = x86_64
license = MIT
@@ -15,6 +15,8 @@ pkgbase = python-jarowinkler
makedepends = ninja
depends = python
source = https://files.pythonhosted.org/packages/source/j/jarowinkler/jarowinkler-1.2.3.tar.gz
+ source = scikit-build.patch
sha256sums = af28ea284cfbd1b21b29ff94b759f20e94e4f7c06f424b0b4702e701c2a21668
+ sha256sums = d74321eed1e4b41ad8dcd81e2412ac5b84602fce147a212ddad32a9ebab3288e
pkgname = python-jarowinkler
diff --git a/.gitignore b/.gitignore
index 018a3de08144..631b176fb85f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
*
+!*.patch
!PKGBUILD
!.SRCINFO
!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index fc14200c8a43..e1cd5ec1dc7c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
-# Maintainer:
+# Maintainer: Bao Trinh <qubidt@gmail.com>
+# Contributor: Antonio Rojas <arojas@archlinux.org>
# Contributor: Pekka Ristola <pekkarr [at] protonmail [dot] com>
_name=jarowinkler
pkgname=python-$_name
pkgver=1.2.3
-pkgrel=1
+pkgrel=2
pkgdesc='A library for fast approximate string matching using Jaro and Jaro-Winkler similarity'
arch=(x86_64)
url='https://github.com/maxbachmann/JaroWinkler'
@@ -13,8 +14,14 @@ depends=(python)
#makedepends=(jarowinkler-cpp python-rapidfuzz-capi python-scikit-build)
makedepends=(python-build python-installer python-setuptools python-scikit-build python-rapidfuzz-capi ninja)
checkdepends=(python-hypothesis python-pytest)
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('af28ea284cfbd1b21b29ff94b759f20e94e4f7c06f424b0b4702e701c2a21668')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz"
+ "scikit-build.patch")
+sha256sums=('af28ea284cfbd1b21b29ff94b759f20e94e4f7c06f424b0b4702e701c2a21668'
+ 'd74321eed1e4b41ad8dcd81e2412ac5b84602fce147a212ddad32a9ebab3288e')
+
+prepare() {
+ patch --directory="${_name}-${pkgver}" --forward --strip=1 --input="${srcdir}/scikit-build.patch"
+}
build() {
cd $_name-$pkgver
diff --git a/scikit-build.patch b/scikit-build.patch
new file mode 100644
index 000000000000..ba5a14c269f2
--- /dev/null
+++ b/scikit-build.patch
@@ -0,0 +1,12 @@
+diff --unified --recursive --text jarowinkler-1.2.3-orig/pyproject.toml jarowinkler-1.2.3/pyproject.toml
+--- jarowinkler-1.2.3-orig/pyproject.toml 2022-09-27 15:18:32.000000000 -0500
++++ jarowinkler-1.2.3/pyproject.toml 2023-05-25 13:31:59.504400391 -0500
+@@ -1,7 +1,7 @@
+ [build-system]
+ requires = [
+ "setuptools>=42",
+- "scikit-build==0.15.0",
++ "scikit-build>=0.15.0",
+ "rapidfuzz_capi==1.0.5"
+ ]
+ build-backend = "backend"