summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bershatsky2023-02-18 19:07:47 +0300
committerDaniel Bershatsky2023-02-18 19:22:44 +0300
commit49c741b055f28ba3dc76cd4cce776e2b34081c72 (patch)
tree5f11be9d3c700aad19e2c3e756be896a1cd242a7
parentce288a392f64e46f16f307129eb67095eab8bfda (diff)
downloadaur-49c741b055f28ba3dc76cd4cce776e2b34081c72.tar.gz
Add missing dependency on wheels
There is a slightly odd dependency issue with `python-build`. The issue is `python-build` produces either source distribution or wheel, so the wheel support is built-in. Moreover, `python-installer` does not depends on `python-wheel` as well because it directly implements "wheel protocol". However, `python-build` uses system wheel package or install it into isolated environment as if there could be different wheel implementations. Not clear.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD4
2 files changed, 4 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b6ca4b47a749..3845572881e4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-jax
pkgdesc = Differentiate, compile, and transform Numpy code.
pkgver = 0.4.4
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/google/jax/
arch = any
groups = jax
@@ -9,6 +9,7 @@ pkgbase = python-jax
makedepends = python-build
makedepends = python-installer
makedepends = python-setuptools
+ makedepends = python-wheel
depends = python-absl
depends = python-jaxlib
depends = python-numpy>=1.20
diff --git a/PKGBUILD b/PKGBUILD
index b5e076fbc5b8..4ee02bba72b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname='python-jax'
pkgver=0.4.4
-pkgrel=1
+pkgrel=2
pkgdesc='Differentiate, compile, and transform Numpy code.'
arch=('any')
url='https://github.com/google/jax/'
@@ -14,7 +14,7 @@ depends=('python-absl'
'python-opt_einsum'
'python-scipy>=1.5')
optdepends=('python-protobuf: Australis')
-makedepends=('python-build' 'python-installer' 'python-setuptools')
+makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
source=("jax-${pkgver}.tar.gz::https://github.com/google/jax/archive/refs/tags/jax-v${pkgver}.tar.gz")
sha256sums=('755eb9b12ab4880e78690f28fc7bd2b491be4e551d8b966e6974753c878dd2c0')