summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bershatsky2021-01-12 15:49:26 +0300
committerDaniel Bershatsky2021-01-12 15:49:26 +0300
commit8756eb6d578d29592eee85a07325ed8dcb818ec0 (patch)
tree6be7fcd60e4967f1effd588a2171b0e629316ecd
downloadaur-8756eb6d578d29592eee85a07325ed8dcb818ec0.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD30
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ba1c1a241698
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = python-jaxlib
+ pkgdesc = Differentiate, compile, and transform Numpy code.
+ pkgver = 0.1.57
+ pkgrel = 1
+ url = https://github.com/google/jax/
+ arch = x86_64
+ license = Apache
+ makedepends = bazel
+ makedepends = gcc
+ makedepends = python-pip
+ makedepends = python-six
+ depends = python
+ depends = python-numpy
+ depends = python-protobuf
+ depends = python-scipy
+ depends = python-wheel
+ source = https://github.com/google/jax/archive/jaxlib-v0.1.57.tar.gz
+ md5sums = 2a6b1acd4d002c6760138f9fc792b736
+
+pkgname = python-jaxlib
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0d11ecbec5c1
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore special directories
+pkg/
+src/
+
+# Ignore archives
+*.tar.gz
+*.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cc248e361783
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Daniel Bershatsky <bepshatsky@yandex.ru>
+
+pkgname=python-jaxlib
+pkgver=0.1.57
+pkgrel=1
+pkgdesc='Differentiate, compile, and transform Numpy code.'
+arch=('x86_64')
+url='https://github.com/google/jax/'
+license=('Apache')
+depends=('python'
+ 'python-numpy'
+ 'python-protobuf'
+ 'python-scipy'
+ 'python-wheel')
+makedepends=('bazel'
+ 'gcc'
+ 'python-pip'
+ 'python-six')
+source=("https://github.com/google/jax/archive/jaxlib-v$pkgver.tar.gz")
+md5sums=('2a6b1acd4d002c6760138f9fc792b736')
+
+build() {
+ cd $srcdir/jax-jaxlib-v$pkgver
+ python build/build.py
+}
+
+package() {
+ cd $srcdir/jax-jaxlib-v$pkgver
+ pip instal --prefix $pkgdir dist/*.whl
+}