summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bershatsky2023-07-28 03:51:05 +0300
committerDaniel Bershatsky2023-07-28 03:51:05 +0300
commitddb92c727d980d4dd90659be877c789592bc0539 (patch)
treea7191f32e170ab50d441e860e2cbf3796cbbead3
parent10b23c72e6ff97305c3e7a010740e89b1bbc449d (diff)
downloadaur-ddb92c727d980d4dd90659be877c789592bc0539.tar.gz
Make main building script more verbose
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD3
-rw-r--r--python-jax.diff18
3 files changed, 23 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 02cb38ac9c49..301ad56aa803 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -17,8 +17,10 @@ pkgbase = python-jaxlib
depends = python-scipy
conflicts = python-jaxlib
source = jaxlib-0.4.14.tar.gz::https://github.com/google/jax/archive/refs/tags/jaxlib-v0.4.14.tar.gz
+ source = python-jax.diff
source = python-jaxlib.diff
sha256sums = 9f309476a8f6337717b059b8d10b5859b4134c30cf8f1220bb70379b5e2744a4
sha256sums = SKIP
+ sha256sums = SKIP
pkgname = python-jaxlib
diff --git a/PKGBUILD b/PKGBUILD
index 2aef83bddb34..991ee07fb79e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,12 +16,15 @@ depends=('python-absl'
makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
conflicts=('python-jaxlib')
source=("jaxlib-${pkgver}.tar.gz::https://github.com/google/jax/archive/refs/tags/jaxlib-v${pkgver}.tar.gz"
+ 'python-jax.diff'
'python-jaxlib.diff')
sha256sums=('9f309476a8f6337717b059b8d10b5859b4134c30cf8f1220bb70379b5e2744a4'
+ 'SKIP'
'SKIP')
prepare() {
cd $srcdir/jax-jaxlib-v$pkgver
+ patch -p1 -i ../python-jax.diff
patch -p1 -i ../python-jaxlib.diff
}
diff --git a/python-jax.diff b/python-jax.diff
new file mode 100644
index 000000000000..70516acaf134
--- /dev/null
+++ b/python-jax.diff
@@ -0,0 +1,18 @@
+--- a/build/build.py 2023-07-28 00:11:05.000000000 +0300
++++ b/build/build.py 2023-07-28 03:46:42.158795877 +0300
+@@ -50,11 +50,12 @@
+
+ def shell(cmd):
+ try:
+- output = subprocess.check_output(cmd)
++ res= subprocess.run(cmd, check=True, capture_output=True)
+ except subprocess.CalledProcessError as e:
+- if e.output: print(e.output)
++ if e.stdout: print(e.stdout)
++ if e.stderr: print(e.stderr)
+ raise
+- return output.decode("UTF-8").strip()
++ return res.stdout.decode("UTF-8").strip()
+
+
+ # Python