summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Bocken2024-05-10 09:16:44 +0200
committerAlexander Bocken2024-05-10 09:16:44 +0200
commitc1a06ab0177d5aa673997be9351d49e6e7c73410 (patch)
tree0d0c46a57f64ff8c4b8adfb3dca00c8c7aeb5841
downloadaur-c1a06ab0177d5aa673997be9351d49e6e7c73410.tar.gz
inital commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD26
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..47eeb47c243e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = python-jaxlib-bin
+ pkgdesc = XLA library for JAX - binary package
+ pkgver = 0.4.28
+ pkgrel = 1
+ url = https://github.com/google/jax
+ arch = x86_64
+ license = Apache
+ makedepends = python-installer
+ makedepends = python-wheel
+ depends = python-absl
+ depends = python-flatbuffers
+ depends = python-ml-dtypes
+ depends = python-numpy
+ depends = python-scipy
+ provides = python-jaxlib=0.4.28
+ conflicts = python-jaxlib
+ noextract = jaxlib-0.4.28-cp312-cp312-manylinux2014_x86_64.whl
+ source = https://files.pythonhosted.org/packages/f3/23/6f38179a0377232192e025939eea99f86239e36c74451a4ba98b6b66a8db/jaxlib-0.4.28-cp312-cp312-manylinux2014_x86_64.whl
+ sha256sums = 46a1aa857f4feee8a43fcba95c0e0ab62d40c26cc9730b6c69655908ba359f8d
+
+pkgname = python-jaxlib-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b8523263e48a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Alexander Bocken <alexander@bocken.org>
+
+_name=jaxlib
+pkgname=python-${_name,,}-bin
+pkgver=0.4.28
+pkgrel=1
+pkgdesc='XLA library for JAX - binary package'
+arch=('x86_64') # TODO make also aarch64 available if possible
+url="https://github.com/google/jax"
+license=('Apache')
+provides=(python-jaxlib=${pkgver})
+conflicts=(python-jaxlib)
+depends=('python-absl'
+ 'python-flatbuffers'
+ 'python-ml-dtypes'
+ 'python-numpy'
+ 'python-scipy')
+makedepends=('python-installer' 'python-wheel')
+_whl="${_name//-/_}-$pkgver-cp312-cp312-manylinux2014_x86_64.whl"
+source=("https://files.pythonhosted.org/packages/f3/23/6f38179a0377232192e025939eea99f86239e36c74451a4ba98b6b66a8db/$_whl") # TODO: cleaner URL
+sha256sums=(46a1aa857f4feee8a43fcba95c0e0ab62d40c26cc9730b6c69655908ba359f8d)
+
+noextract=("$_whl")
+package() {
+ python -m installer --destdir="$pkgdir" "$_whl"
+}