summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bershatsky2023-06-01 22:16:37 +0300
committerDaniel Bershatsky2023-06-01 22:16:37 +0300
commit42021cd104e661925fd1b15d655a18752c70d0bc (patch)
tree32046ac41424ac9868b49d6671e5872a56dd55f5
parent1c0041950b765c3f12e82424d1048dbc8a4278f5 (diff)
downloadaur-42021cd104e661925fd1b15d655a18752c70d0bc.tar.gz
Bump version to 0.2.20
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 710ee933a631..c5ba1eb14555 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-jaxtyping
pkgdesc = Type annotations and runtime checking for shape and dtype of JAX arrays, and PyTrees.
- pkgver = 0.2.19
+ pkgver = 0.2.20
pkgrel = 1
url = https://github.com/google/jaxtyping
arch = any
@@ -15,7 +15,7 @@ pkgbase = python-jaxtyping
depends = python-typing_extensions
optdepends = python-jax: Original JAX type system support.
optdepends = python-pytest: Extension for pytest with jaxtyping plugin.
- source = python-jaxtyping-0.2.19.tar.gz::https://github.com/google/jaxtyping/archive/refs/tags/v0.2.19.tar.gz
- sha256sums = 075521fdfd7b5d5303d9ba6c88fe271d34b9c362da909f4c74a3d51b6beac179
+ source = python-jaxtyping-0.2.20.tar.gz::https://github.com/google/jaxtyping/archive/refs/tags/v0.2.20.tar.gz
+ sha256sums = ed4fdbebc96f87a40e8f834ec4739381c0c110d43cd0b4268b671e981d8140a8
pkgname = python-jaxtyping
diff --git a/PKGBUILD b/PKGBUILD
index 1d1d680d0412..0d5f5dacf948 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bershatsky <bepshatsky@yandex.ru>
pkgname=python-jaxtyping
_pkgname=${pkgname#python-}
-pkgver=0.2.19
+pkgver=0.2.20
pkgrel=1
pkgdesc='Type annotations and runtime checking for shape and dtype of JAX arrays, and PyTrees.'
arch=('any')
@@ -17,7 +17,7 @@ makedepends=('python-build' 'python-hatchling' 'python-installer' 'python-wheel'
optdepends=('python-jax: Original JAX type system support.'
'python-pytest: Extension for pytest with jaxtyping plugin.')
source=("$pkgname-$pkgver.tar.gz::https://github.com/google/$_pkgname/archive/refs/tags/v$pkgver.tar.gz")
-sha256sums=('075521fdfd7b5d5303d9ba6c88fe271d34b9c362da909f4c74a3d51b6beac179')
+sha256sums=('ed4fdbebc96f87a40e8f834ec4739381c0c110d43cd0b4268b671e981d8140a8')
build() {
python -m build -n -w $_pkgname-$pkgver