summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bershatsky2023-10-11 22:07:55 +0300
committerDaniel Bershatsky2023-10-11 22:07:55 +0300
commit4e6f0a9f8a6f962c7c37f6705a61491b1a1114fc (patch)
tree4c5a6c4e7134b8ce54b135573868c2ba2995445a
parent75c03964041e64efc3abefa4fee0999c6b63fa08 (diff)
downloadaur-4e6f0a9f8a6f962c7c37f6705a61491b1a1114fc.tar.gz
Bump to version 0.2.23
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 19cef906802b..806463ae2912 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-jaxtyping
pkgdesc = Type annotations and runtime checking for shape and dtype of JAX arrays, and PyTrees.
- pkgver = 0.2.21
+ pkgver = 0.2.23
pkgrel = 1
url = https://github.com/google/jaxtyping
arch = any
@@ -15,7 +15,7 @@ pkgbase = python-jaxtyping
depends = python-typing_extensions
optdepends = python-jax: Original JAX type system support.
optdepends = python-pytest: Extension for pytest with jaxtyping plugin.
- source = python-jaxtyping-0.2.21.tar.gz::https://github.com/google/jaxtyping/archive/refs/tags/v0.2.21.tar.gz
- sha256sums = 6d5d66d9dae9319e179a2233df95bb038fe7f9455a4ebb6e1501f4cac22a3ae3
+ source = python-jaxtyping-0.2.23.tar.gz::https://github.com/google/jaxtyping/archive/refs/tags/v0.2.23.tar.gz
+ sha256sums = 22679d1ba81e0e98c9b85e84a81b05df1e07c460994b635c411715a434764bee
pkgname = python-jaxtyping
diff --git a/PKGBUILD b/PKGBUILD
index c3503aba06c3..a27c200f88f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bershatsky <bepshatsky@yandex.ru>
pkgname=python-jaxtyping
_pkgname=${pkgname#python-}
-pkgver=0.2.21
+pkgver=0.2.23
pkgrel=1
pkgdesc='Type annotations and runtime checking for shape and dtype of JAX arrays, and PyTrees.'
arch=('any')
@@ -17,10 +17,10 @@ makedepends=('python-build' 'python-hatchling' 'python-installer' 'python-wheel'
optdepends=('python-jax: Original JAX type system support.'
'python-pytest: Extension for pytest with jaxtyping plugin.')
source=("$pkgname-$pkgver.tar.gz::https://github.com/google/$_pkgname/archive/refs/tags/v$pkgver.tar.gz")
-sha256sums=('6d5d66d9dae9319e179a2233df95bb038fe7f9455a4ebb6e1501f4cac22a3ae3')
+sha256sums=('22679d1ba81e0e98c9b85e84a81b05df1e07c460994b635c411715a434764bee')
build() {
- python -m build -n -w $_pkgname-$pkgver
+ python -m build -nw $_pkgname-$pkgver
}
package() {