summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bershatsky2023-02-18 23:39:02 +0300
committerDaniel Bershatsky2023-02-18 23:39:02 +0300
commit961c09e564f28bf8c9014e5e937ce3285ef487f2 (patch)
tree65e0f7791b22df2d02935b6374aecbbd78ae0358
parentc559db71d7595372e8986370f66bc83239761af2 (diff)
downloadaur-961c09e564f28bf8c9014e5e937ce3285ef487f2.tar.gz
Add missing make dependency
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD4
2 files changed, 4 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cc11f366448e..ab0c50993af2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-jaxtyping
pkgdesc = Type annotations and runtime checking for shape and dtype of JAX arrays, and PyTrees.
pkgver = 0.2.12
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/google/jaxtyping
arch = any
groups = jax
@@ -9,6 +9,7 @@ pkgbase = python-jaxtyping
makedepends = python-build
makedepends = python-installer
makedepends = python-setuptools
+ makedepends = python-wheel
depends = python-numpy
depends = python-typeguard
depends = python-typing_extensions
diff --git a/PKGBUILD b/PKGBUILD
index 4706758502d5..7c7a3e71aa9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=python-jaxtyping
_pkgname=${pkgname#python-}
pkgver=0.2.12
-pkgrel=1
+pkgrel=2
pkgdesc='Type annotations and runtime checking for shape and dtype of JAX arrays, and PyTrees.'
arch=('any')
url="https://github.com/google/jaxtyping"
@@ -13,7 +13,7 @@ depends=(
'python-typeguard'
'python-typing_extensions'
)
-makedepends=('python-build' 'python-installer' 'python-setuptools')
+makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
optdepends=('python-jax: Original JAX type system support.'
'python-pytest: Extension for pytest with jaxtyping plugin.')
source=("$pkgname-$pkgver.tar.gz::https://github.com/google/$_pkgname/archive/refs/tags/v$pkgver.tar.gz")