summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bershatsky2023-12-16 06:54:27 +0300
committerDaniel Bershatsky2023-12-16 06:54:27 +0300
commitbfe61a2a172e142316b4ced0b7af53b77042f31e (patch)
tree418ec44e6e73d5d19f67f9d326fc04a7d0baa2da
parent4e6f0a9f8a6f962c7c37f6705a61491b1a1114fc (diff)
downloadaur-bfe61a2a172e142316b4ced0b7af53b77042f31e.tar.gz
Bump version to 0.2.25
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 806463ae2912..6e9c0badcae6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-jaxtyping
pkgdesc = Type annotations and runtime checking for shape and dtype of JAX arrays, and PyTrees.
- pkgver = 0.2.23
+ pkgver = 0.2.25
pkgrel = 1
url = https://github.com/google/jaxtyping
arch = any
@@ -15,7 +15,7 @@ pkgbase = python-jaxtyping
depends = python-typing_extensions
optdepends = python-jax: Original JAX type system support.
optdepends = python-pytest: Extension for pytest with jaxtyping plugin.
- source = python-jaxtyping-0.2.23.tar.gz::https://github.com/google/jaxtyping/archive/refs/tags/v0.2.23.tar.gz
- sha256sums = 22679d1ba81e0e98c9b85e84a81b05df1e07c460994b635c411715a434764bee
+ source = python-jaxtyping-0.2.25.tar.gz::https://github.com/google/jaxtyping/archive/refs/tags/v0.2.25.tar.gz
+ sha256sums = d1171ae18e805178dfa04078de0d1ff8b06c2aafc74f0325f14b3d3dc6466ba7
pkgname = python-jaxtyping
diff --git a/PKGBUILD b/PKGBUILD
index a27c200f88f7..ee582fe51583 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bershatsky <bepshatsky@yandex.ru>
pkgname=python-jaxtyping
_pkgname=${pkgname#python-}
-pkgver=0.2.23
+pkgver=0.2.25
pkgrel=1
pkgdesc='Type annotations and runtime checking for shape and dtype of JAX arrays, and PyTrees.'
arch=('any')
@@ -17,7 +17,7 @@ makedepends=('python-build' 'python-hatchling' 'python-installer' 'python-wheel'
optdepends=('python-jax: Original JAX type system support.'
'python-pytest: Extension for pytest with jaxtyping plugin.')
source=("$pkgname-$pkgver.tar.gz::https://github.com/google/$_pkgname/archive/refs/tags/v$pkgver.tar.gz")
-sha256sums=('22679d1ba81e0e98c9b85e84a81b05df1e07c460994b635c411715a434764bee')
+sha256sums=('d1171ae18e805178dfa04078de0d1ff8b06c2aafc74f0325f14b3d3dc6466ba7')
build() {
python -m build -nw $_pkgname-$pkgver