summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bershatsky2023-02-17 01:03:19 +0300
committerDaniel Bershatsky2023-02-17 01:11:18 +0300
commitc559db71d7595372e8986370f66bc83239761af2 (patch)
tree19fc0a9224374591cd54da6c87fca75ebc2d3e83
downloadaur-c559db71d7595372e8986370f66bc83239761af2.tar.gz
Initial commit from version 0.2.12
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD31
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cc11f366448e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python-jaxtyping
+ pkgdesc = Type annotations and runtime checking for shape and dtype of JAX arrays, and PyTrees.
+ pkgver = 0.2.12
+ pkgrel = 1
+ url = https://github.com/google/jaxtyping
+ arch = any
+ groups = jax
+ license = Apache
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-setuptools
+ depends = python-numpy
+ depends = python-typeguard
+ depends = python-typing_extensions
+ optdepends = python-jax: Original JAX type system support.
+ optdepends = python-pytest: Extension for pytest with jaxtyping plugin.
+ source = python-jaxtyping-0.2.12.tar.gz::https://github.com/google/jaxtyping/archive/refs/tags/v0.2.12.tar.gz
+ sha256sums = 3e8686182078974a60101a41f88005bc2a0f3c4080369759ea82bb314d050f7a
+
+pkgname = python-jaxtyping
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4706758502d5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Daniel Bershatsky <bepshatsky@yandex.ru>
+pkgname=python-jaxtyping
+_pkgname=${pkgname#python-}
+pkgver=0.2.12
+pkgrel=1
+pkgdesc='Type annotations and runtime checking for shape and dtype of JAX arrays, and PyTrees.'
+arch=('any')
+url="https://github.com/google/jaxtyping"
+license=('Apache')
+groups=('jax')
+depends=(
+ 'python-numpy'
+ 'python-typeguard'
+ 'python-typing_extensions'
+)
+makedepends=('python-build' 'python-installer' 'python-setuptools')
+optdepends=('python-jax: Original JAX type system support.'
+ 'python-pytest: Extension for pytest with jaxtyping plugin.')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/google/$_pkgname/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('3e8686182078974a60101a41f88005bc2a0f3c4080369759ea82bb314d050f7a')
+
+build() {
+ python -m build -n -w $_pkgname-$pkgver
+}
+
+package() {
+ python -m installer \
+ --compile-bytecode 1 \
+ --destdir $pkgdir \
+ $_pkgname-$pkgver/dist/$_pkgname-$pkgver-*.whl
+}