summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bershatsky2024-03-10 14:38:59 +0300
committerDaniel Bershatsky2024-03-10 14:38:59 +0300
commited4c806e4ea47433105c98dce06ebbb5364b9681 (patch)
tree1be1526d50cacb9be168d05e2c19beb778926632
parent98add5082fd50f7ac55bc28a6baa07214f6a8664 (diff)
downloadaur-ed4c806e4ea47433105c98dce06ebbb5364b9681.tar.gz
Bump version to 0.2.27
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 141b5e2cf7d2..df6a4655e13a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-jaxtyping
pkgdesc = Type annotations and runtime checking for shape and dtype of JAX arrays, and PyTrees.
- pkgver = 0.2.26
+ pkgver = 0.2.27
pkgrel = 1
url = https://github.com/google/jaxtyping
arch = any
@@ -14,7 +14,7 @@ pkgbase = python-jaxtyping
depends = python-typeguard
optdepends = python-jax: Original JAX type system support.
optdepends = python-pytest: Extension for pytest with jaxtyping plugin.
- source = python-jaxtyping-0.2.26.tar.gz::https://github.com/google/jaxtyping/archive/refs/tags/v0.2.26.tar.gz
- sha256sums = db3f53eba6faa9c1081655a2bd3be08d0524f042d39e082b972520e3a39f7070
+ source = python-jaxtyping-0.2.27.tar.gz::https://github.com/google/jaxtyping/archive/refs/tags/v0.2.27.tar.gz
+ sha256sums = 2fd55da9f1ea906769046e237d3d4e5bc838d1cced48f6cee45fd1986dc9471b
pkgname = python-jaxtyping
diff --git a/PKGBUILD b/PKGBUILD
index 1b10d93d8be9..d2e2b628041f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bershatsky <bepshatsky@yandex.ru>
pkgname=python-jaxtyping
_pkgname=${pkgname#python-}
-pkgver=0.2.26
+pkgver=0.2.27
pkgrel=1
pkgdesc='Type annotations and runtime checking for shape and dtype of JAX arrays, and PyTrees.'
arch=('any')
@@ -16,7 +16,7 @@ makedepends=('python-build' 'python-hatchling' 'python-installer' 'python-wheel'
optdepends=('python-jax: Original JAX type system support.'
'python-pytest: Extension for pytest with jaxtyping plugin.')
source=("$pkgname-$pkgver.tar.gz::https://github.com/google/$_pkgname/archive/refs/tags/v$pkgver.tar.gz")
-sha256sums=('db3f53eba6faa9c1081655a2bd3be08d0524f042d39e082b972520e3a39f7070')
+sha256sums=('2fd55da9f1ea906769046e237d3d4e5bc838d1cced48f6cee45fd1986dc9471b')
build() {
python -m build -nw $_pkgname-$pkgver