summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam Whited2019-04-20 11:37:19 -0500
committerSam Whited2019-04-20 11:37:19 -0500
commite373f11927e9ea3cedbc9eb552ea47dbba6a1268 (patch)
tree3aef5baa06cbcce2cdce0f906224f34ae16743a7
downloadaur-e373f11927e9ea3cedbc9eb552ea47dbba6a1268.tar.gz
Initial version
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD33
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6c8cb4dee195
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-jclib-git
+ pkgdesc = The core of the jabbercat XMPP client
+ pkgver = v0.1.0.r223.d34055ea0110
+ pkgrel = 1
+ url = https://jabbercat.org
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ depends = python
+ depends = python-hsluv
+ provides = python-jclib
+ conflicts = python-jclib
+ source = python-jclib-git::git+https://github.com/jabbercat/jclib.git
+ sha256sums = SKIP
+
+pkgname = python-jclib-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..00ebee8761c7
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pkg/
+python-jclib-git/
+src/
+*.tar.gz
+*.tar.xz
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..637d1bd91671
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Sam Whited <sam@samwhited.com>
+
+pkgname=python-jclib-git
+conflicts=('python-jclib')
+provides=('python-jclib')
+pkgver=v0.1.0.r223.d34055ea0110
+pkgrel=1
+pkgdesc='The core of the jabbercat XMPP client'
+arch=('any')
+url='https://jabbercat.org'
+license=('GPL3')
+depends=('python'
+ 'python-hsluv')
+makedepends=('python-setuptools')
+source=("$pkgname::git+https://github.com/jabbercat/jclib.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ printf "v%s.r%s.%s" "$(python setup.py --version)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd $pkgname
+ python setup.py build
+}
+
+package() {
+ cd $pkgname
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}
+
+# vim:set ts=2 sw=2 et: