summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYen Chi Hsuan2016-07-04 17:22:43 +0800
committerYen Chi Hsuan2016-07-04 17:22:43 +0800
commit0dc1ce1b24251fe554363eba10a1a85568c70415 (patch)
treeef8f132b3a168a3133d3780e404e8f039df36cfa
parentc8627811e0b06781eded87e1c0003b3d05be5f58 (diff)
downloadaur-0dc1ce1b24251fe554363eba10a1a85568c70415.tar.gz
Use upstream repo
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD19
3 files changed, 21 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 43118ba59d46..459c0ec3d2a5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,20 @@
# Generated by mksrcinfo v8
-# Sun Jul 3 19:15:58 UTC 2016
+# Mon Jul 4 09:22:30 UTC 2016
pkgbase = python-jedihttp-git
- pkgdesc = Simple http wrapper around jedi (yan12125's fork)
+ pkgdesc = Simple http wrapper around jedi (with yan12125's packaging patch)
pkgver = r144.d9f9f3c
pkgrel = 1
- url = https://github.com/yan12125/JediHTTP
+ url = https://github.com/vheon/JediHTTP
arch = any
license = Apache
makedepends = python-setuptools
depends = python-bottle
depends = python-jedi
depends = python-waitress
- source = git+https://github.com/yan12125/JediHTTP#branch=packaging
+ source = git+https://github.com/vheon/JediHTTP
+ source = packaging.patch::https://github.com/vheon/JediHTTP/compare/master...yan12125:packaging.patch
sha256sums = SKIP
+ sha256sums = fe4e479ed0c616608ec35150965f696fa1e9daae1b9209adbb51131dda294f54
pkgname = python-jedihttp-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6930f451c8ec
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+/python-jedihttp-git/
+/python2-jedihttp-git/
diff --git a/PKGBUILD b/PKGBUILD
index a8be646d3ffd..c44479ad3f48 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,16 @@
pkgname=python-jedihttp-git
pkgver=r144.d9f9f3c
pkgrel=1
-pkgdesc="Simple http wrapper around jedi (yan12125's fork)"
+pkgdesc="Simple http wrapper around jedi (with yan12125's packaging patch)"
license=('Apache')
arch=('any')
-url='https://github.com/yan12125/JediHTTP'
+url='https://github.com/vheon/JediHTTP'
depends=('python-bottle' 'python-jedi' 'python-waitress')
makedepends=('python-setuptools')
-source=('git+https://github.com/yan12125/JediHTTP#branch=packaging')
-sha256sums=('SKIP')
+source=('git+https://github.com/vheon/JediHTTP'
+ 'packaging.patch'::'https://github.com/vheon/JediHTTP/compare/master...yan12125:packaging.patch')
+sha256sums=('SKIP'
+ 'fe4e479ed0c616608ec35150965f696fa1e9daae1b9209adbb51131dda294f54')
pkgver() {
cd "$srcdir/JediHTTP"
@@ -21,7 +23,12 @@ pkgver() {
)
}
+prepare() {
+ cd "${srcdir}/JediHTTP"
+ patch -i ../packaging.patch -p1
+}
+
package() {
- cd "${srcdir}/JediHTTP"
- python setup.py install --root="${pkgdir}" --optimize=1
+ cd "${srcdir}/JediHTTP"
+ python setup.py install --root="${pkgdir}" --optimize=1
}