summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYen Chi Hsuan2016-07-09 15:16:30 +0800
committerYen Chi Hsuan2016-07-09 15:16:30 +0800
commit1f63ea72b0d750b1039b6dc749ebefa28589236e (patch)
treef9ae18ae0facfd71d87f2aaafe8769279c7fc6aa
parent69d2e7ce54d9f91181d8d1aad8900b00c6fc4db4 (diff)
downloadaur-1f63ea72b0d750b1039b6dc749ebefa28589236e.tar.gz
Maintain patches locally
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD14
-rw-r--r--allow-missing-vendor.patch14
-rw-r--r--setup.py33
4 files changed, 63 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9e9af0fb6b31..c2eb974acb39 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,24 @@
# Generated by mksrcinfo v8
-# Mon Jul 4 22:03:24 UTC 2016
+# Sat Jul 9 07:16:12 UTC 2016
pkgbase = python-jedihttp-git
pkgdesc = Simple http wrapper around jedi (with yan12125's packaging patch)
pkgver = r141.ec6e097
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/vheon/JediHTTP
arch = any
license = Apache
makedepends = python-setuptools
+ makedepends = git
depends = python-bottle
depends = python-jedi
depends = python-waitress
conflicts = python2-jedihttp-git
source = git+https://github.com/vheon/JediHTTP
- source = packaging.patch::https://github.com/vheon/JediHTTP/compare/master...yan12125:packaging.patch
+ source = setup.py
+ source = allow-missing-vendor.patch
sha256sums = SKIP
- sha256sums = fe4e479ed0c616608ec35150965f696fa1e9daae1b9209adbb51131dda294f54
+ sha256sums = 6454c24288fad1a79ed0b3c7fa70902b87084384037ce5edab5be4eb4e4138d1
+ sha256sums = 865e91d405de332c128c53d901702fd621000868f78482602874d254abb755a3
pkgname = python-jedihttp-git
diff --git a/PKGBUILD b/PKGBUILD
index 7f247ffe01fa..c300845c1617 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,19 @@
pkgname=python-jedihttp-git
pkgver=r141.ec6e097
-pkgrel=2
+pkgrel=3
pkgdesc="Simple http wrapper around jedi (with yan12125's packaging patch)"
license=('Apache')
arch=('any')
url='https://github.com/vheon/JediHTTP'
depends=('python-bottle' 'python-jedi' 'python-waitress')
-makedepends=('python-setuptools')
+makedepends=('python-setuptools' 'git')
source=('git+https://github.com/vheon/JediHTTP'
- 'packaging.patch'::'https://github.com/vheon/JediHTTP/compare/master...yan12125:packaging.patch')
+ 'setup.py'
+ 'allow-missing-vendor.patch')
sha256sums=('SKIP'
- 'fe4e479ed0c616608ec35150965f696fa1e9daae1b9209adbb51131dda294f54')
+ '6454c24288fad1a79ed0b3c7fa70902b87084384037ce5edab5be4eb4e4138d1'
+ '865e91d405de332c128c53d901702fd621000868f78482602874d254abb755a3')
conflicts=('python2-jedihttp-git')
pkgver() {
@@ -26,7 +28,9 @@ pkgver() {
prepare() {
cd "${srcdir}/JediHTTP"
- patch -i ../packaging.patch -p1
+ patch -i ../allow-missing-vendor.patch -p1
+ ln -s ../setup.py
+ mv jedihttp{,-main}.py
}
package() {
diff --git a/allow-missing-vendor.patch b/allow-missing-vendor.patch
new file mode 100644
index 000000000000..97f7f1609c4c
--- /dev/null
+++ b/allow-missing-vendor.patch
@@ -0,0 +1,14 @@
+diff --git a/jedihttp/utils.py b/jedihttp/utils.py
+index 4c5e92e..be57291 100644
+--- a/jedihttp/utils.py
++++ b/jedihttp/utils.py
+@@ -19,6 +19,8 @@ def AddVendorFolderToSysPath():
+ vendor_folder = os.path.join( os.path.dirname( __file__ ),
+ '..',
+ 'vendor' )
++ if not os.path.exists( vendor_folder ):
++ return
+
+ for folder in os.listdir( vendor_folder ):
+ sys.path.insert( 0, os.path.realpath( os.path.join( vendor_folder,
+
diff --git a/setup.py b/setup.py
new file mode 100644
index 000000000000..bd0224f8977d
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,33 @@
+import sys
+from setuptools import setup
+
+dependencies = ['waitress', 'jedi', 'bottle']
+
+if sys.version_info[:2] == (2, 6):
+ dependencies.append('argparse')
+
+setup(
+ name='jedihttp',
+ version='0.0.1',
+ description='Simple http wrapper around jedi',
+ url='https://github.com/vheon/JediHTTP/',
+ author='Andrea Cedraro',
+ author_email='a.cedraro@gmail.com',
+ packages=['jedihttp'],
+
+ classifiers=[
+ 'Topic :: Text Editors',
+ 'Development Status :: 5 - Production/Stable',
+ 'Environment :: Console',
+ 'License :: OSI Approved :: Apache Software License',
+ 'Programming Language :: Python :: 2.6',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.3',
+ 'Programming Language :: Python :: 3.4',
+ 'Programming Language :: Python :: 3.5',
+ ],
+
+ scripts=['jedihttp-main.py'],
+ install_requires=dependencies,
+)