summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYen Chi Hsuan2017-01-10 00:28:53 +0800
committerYen Chi Hsuan2017-01-10 00:28:53 +0800
commit3c1568f157ef5927da8bc25c6846d6790b22dc48 (patch)
tree3c765ec3143dc89032fdab76470f7dd03d584945
parentfe166a67615452b962b658c4be0464bee804f856 (diff)
downloadaur-3c1568f157ef5927da8bc25c6846d6790b22dc48.tar.gz
Bump to r150.c376aad
Unsplit packages. yaourt is buggy and I waste time on workarounding it. Now turn to pacaur!
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD22
2 files changed, 29 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 416e7abad5eb..85ebd2d33466 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,15 @@
# Generated by mksrcinfo v8
-# Sun Jan 1 17:56:19 UTC 2017
+# Mon Jan 9 16:28:44 UTC 2017
pkgbase = python-jedihttp-git
pkgdesc = Simple http wrapper around jedi (with yan12125's packaging patch)
- pkgver = r147.d6fcdc2
+ pkgver = r150.c376aad
pkgrel = 1
url = https://github.com/vheon/JediHTTP
arch = any
license = Apache
makedepends = python-setuptools
+ makedepends = python2-setuptools
makedepends = git
- depends = python-bottle
- depends = python-jedi
- depends = python-waitress
- conflicts = python2-jedihttp-git
source = git+https://github.com/vheon/JediHTTP
source = setup.py
source = allow-missing-vendor.patch
@@ -21,4 +18,14 @@ pkgbase = python-jedihttp-git
sha256sums = 8702390e2643fe7e64d0b4c9477ffec1d83d1865bd21ab4b61f9ed8aa130c013
pkgname = python-jedihttp-git
+ depends = python-bottle
+ depends = python-jedi
+ depends = python-waitress
+ conflicts = python2-jedihttp-git
+
+pkgname = python2-jedihttp-git
+ depends = python2-bottle
+ depends = python2-jedi
+ depends = python2-waitress
+ conflicts = python-jedihttp-git
diff --git a/PKGBUILD b/PKGBUILD
index bf7ac833cce2..a3cca9bfa874 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,21 @@
# vim: set filetype=sh:
# Maintainer: Yen Chi Hsuan <yan12125@gmail.com>
-pkgname=python-jedihttp-git
-pkgver=r147.d6fcdc2
+pkgbase=python-jedihttp-git
+pkgname=(python-jedihttp-git python2-jedihttp-git)
+pkgver=r150.c376aad
pkgrel=1
pkgdesc="Simple http wrapper around jedi (with yan12125's packaging patch)"
license=('Apache')
arch=('any')
url='https://github.com/vheon/JediHTTP'
-depends=('python-bottle' 'python-jedi' 'python-waitress')
-makedepends=('python-setuptools' 'git')
+makedepends=('python-setuptools' 'python2-setuptools' 'git')
source=('git+https://github.com/vheon/JediHTTP'
'setup.py'
'allow-missing-vendor.patch')
sha256sums=('SKIP'
'6454c24288fad1a79ed0b3c7fa70902b87084384037ce5edab5be4eb4e4138d1'
'8702390e2643fe7e64d0b4c9477ffec1d83d1865bd21ab4b61f9ed8aa130c013')
-conflicts=('python2-jedihttp-git')
pkgver() {
cd "$srcdir/JediHTTP"
@@ -33,7 +32,18 @@ prepare() {
mv jedihttp{,-main}.py
}
-package() {
+package_python-jedihttp-git() {
+ depends=('python-bottle' 'python-jedi' 'python-waitress')
+ conflicts=('python2-jedihttp-git')
+
cd "${srcdir}/JediHTTP"
python setup.py install --root="${pkgdir}" --optimize=1
}
+
+package_python2-jedihttp-git() {
+ depends=('python2-bottle' 'python2-jedi' 'python2-waitress')
+ conflicts=('python-jedihttp-git')
+
+ cd "${srcdir}/JediHTTP"
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+}