summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYen Chi Hsuan2017-01-02 01:54:59 +0800
committerYen Chi Hsuan2017-01-02 01:54:59 +0800
commit8af1fba95ef972b89d6ee9d69daf5c9d27217a5d (patch)
treeb1afbe1b53cde869d332b7a105ae95d14f34f1f0
parent4378b70771e181aab3f14adbb329efe11a043f99 (diff)
downloadaur-8af1fba95ef972b89d6ee9d69daf5c9d27217a5d.tar.gz
Update patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD2
-rw-r--r--allow-missing-vendor.patch14
3 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d32605adaff3..094bd8cbb500 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Fri Oct 28 15:01:29 UTC 2016
+# Sun Jan 1 17:54:58 UTC 2017
pkgbase = python-jedihttp-git
pkgdesc = Simple http wrapper around jedi (with yan12125's packaging patch)
pkgver = r146.1e572e2
@@ -18,7 +18,7 @@ pkgbase = python-jedihttp-git
source = allow-missing-vendor.patch
sha256sums = SKIP
sha256sums = 6454c24288fad1a79ed0b3c7fa70902b87084384037ce5edab5be4eb4e4138d1
- sha256sums = 865e91d405de332c128c53d901702fd621000868f78482602874d254abb755a3
+ sha256sums = 8702390e2643fe7e64d0b4c9477ffec1d83d1865bd21ab4b61f9ed8aa130c013
pkgname = python-jedihttp-git
diff --git a/PKGBUILD b/PKGBUILD
index 755f330a3bad..cee10cce8b82 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,7 @@ source=('git+https://github.com/vheon/JediHTTP'
'allow-missing-vendor.patch')
sha256sums=('SKIP'
'6454c24288fad1a79ed0b3c7fa70902b87084384037ce5edab5be4eb4e4138d1'
- '865e91d405de332c128c53d901702fd621000868f78482602874d254abb755a3')
+ '8702390e2643fe7e64d0b4c9477ffec1d83d1865bd21ab4b61f9ed8aa130c013')
conflicts=('python2-jedihttp-git')
pkgver() {
diff --git a/allow-missing-vendor.patch b/allow-missing-vendor.patch
index 97f7f1609c4c..93bcd31b14ff 100644
--- a/allow-missing-vendor.patch
+++ b/allow-missing-vendor.patch
@@ -1,14 +1,14 @@
diff --git a/jedihttp/utils.py b/jedihttp/utils.py
-index 4c5e92e..be57291 100644
+index f04372a..acec90c 100644
--- a/jedihttp/utils.py
+++ b/jedihttp/utils.py
-@@ -19,6 +19,8 @@ def AddVendorFolderToSysPath():
- vendor_folder = os.path.join( os.path.dirname( __file__ ),
- '..',
- 'vendor' )
+@@ -18,6 +18,9 @@ import sys
+ def AddVendorFolderToSysPath():
+ vendor_folder = os.path.join( os.path.dirname( __file__ ), '..', 'vendor' )
+
+ if not os.path.exists( vendor_folder ):
+ return
-
++
for folder in os.listdir( vendor_folder ):
sys.path.insert( 0, os.path.realpath( os.path.join( vendor_folder,
-
+ folder ) ) )