summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYen Chi Hsuan2016-07-04 03:16:19 +0800
committerYen Chi Hsuan2016-07-04 03:16:19 +0800
commitc8627811e0b06781eded87e1c0003b3d05be5f58 (patch)
treeef13a104227cba1353c93ad10426eafbfa7b14d0
downloadaur-c8627811e0b06781eded87e1c0003b3d05be5f58.tar.gz
New package
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD27
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..43118ba59d46
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Sun Jul 3 19:15:58 UTC 2016
+pkgbase = python-jedihttp-git
+ pkgdesc = Simple http wrapper around jedi (yan12125's fork)
+ pkgver = r144.d9f9f3c
+ pkgrel = 1
+ url = https://github.com/yan12125/JediHTTP
+ arch = any
+ license = Apache
+ makedepends = python-setuptools
+ depends = python-bottle
+ depends = python-jedi
+ depends = python-waitress
+ source = git+https://github.com/yan12125/JediHTTP#branch=packaging
+ sha256sums = SKIP
+
+pkgname = python-jedihttp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a8be646d3ffd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# vim: set filetype=sh:
+# Maintainer: Yen Chi Hsuan <yan12125@gmail.com>
+
+pkgname=python-jedihttp-git
+pkgver=r144.d9f9f3c
+pkgrel=1
+pkgdesc="Simple http wrapper around jedi (yan12125's fork)"
+license=('Apache')
+arch=('any')
+url='https://github.com/yan12125/JediHTTP'
+depends=('python-bottle' 'python-jedi' 'python-waitress')
+makedepends=('python-setuptools')
+source=('git+https://github.com/yan12125/JediHTTP#branch=packaging')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/JediHTTP"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+package() {
+ cd "${srcdir}/JediHTTP"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}