summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChih-Hsuan Yen2018-03-15 21:27:02 +0800
committerChih-Hsuan Yen2018-03-15 21:27:02 +0800
commite4bc7cdd02ba10fc77806ed24bf9262c81349e30 (patch)
tree16d6e1bb038867ebc4dca181a8e017571a32a0de
parent8c5823161c8e7362bad541457d7e0e85b0e715f5 (diff)
downloadaur-e4bc7cdd02ba10fc77806ed24bf9262c81349e30.tar.gz
correct makedepends
Discovered by namcap
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD23
2 files changed, 36 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 30f11bf75b57..808b74a6adf3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,32 @@
pkgbase = python-jedihttp-git
pkgdesc = Simple http wrapper around jedi (with yan12125's packaging patch)
- pkgver = r172.3d3dcf4
- pkgrel = 1
+ pkgver = r178.d283a73
+ pkgrel = 3
url = https://github.com/vheon/JediHTTP
arch = any
license = Apache
checkdepends = python-tox
- checkdepends = python2-bottle
- checkdepends = python2-jedi
- checkdepends = python2-waitress
- checkdepends = python-bottle
- checkdepends = python-jedi
- checkdepends = python-waitress
+ checkdepends = python2-flake8
+ checkdepends = python2-nose
+ checkdepends = python2-webtest
+ checkdepends = python2-pyhamcrest
+ checkdepends = python2-requests
+ checkdepends = python2-coverage
+ checkdepends = flake8
+ checkdepends = python-nose
+ checkdepends = python-webtest
+ checkdepends = python-pyhamcrest
+ checkdepends = python-requests
+ checkdepends = python-coverage
makedepends = python-setuptools
makedepends = python2-setuptools
makedepends = git
+ makedepends = python2-bottle
+ makedepends = python2-jedi
+ makedepends = python2-waitress
+ makedepends = python-bottle
+ makedepends = python-jedi
+ makedepends = python-waitress
source = git+https://github.com/vheon/JediHTTP
source = setup.py
source = allow-missing-vendor.patch
diff --git a/PKGBUILD b/PKGBUILD
index b074fe69058a..f3b76a562cc9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,26 @@
pkgbase=python-jedihttp-git
pkgname=(python-jedihttp-git python2-jedihttp-git)
-pkgver=r172.3d3dcf4
-pkgrel=1
+pkgver=r178.d283a73
+pkgrel=3
pkgdesc="Simple http wrapper around jedi (with yan12125's packaging patch)"
license=('Apache')
arch=('any')
url='https://github.com/vheon/JediHTTP'
-makedepends=('python-setuptools' 'python2-setuptools' 'git')
+makedepends=('python-setuptools' 'python2-setuptools' 'git'
+ 'python2-bottle' 'python2-jedi' 'python2-waitress'
+ 'python-bottle' 'python-jedi' 'python-waitress')
+# See test_requirements.txt for checkdepends
checkdepends=(
'python-tox'
- 'python2-bottle' 'python2-jedi' 'python2-waitress'
- 'python-bottle' 'python-jedi' 'python-waitress')
+ # XXX: webtest and coverage are installed by tox anyway as jedihttp requires older versions for them,
+ # while the nosetests command uses globally-installed packages
+ 'python2-flake8' 'python2-nose' 'python2-webtest' 'python2-pyhamcrest' 'python2-requests' 'python2-coverage'
+ 'flake8' 'python-nose' 'python-webtest' 'python-pyhamcrest' 'python-requests' 'python-coverage'
+ # Missing packages. They are not necessary for packaging as we don't run flake8 tests in check().
+ # 'python2-pep8-naming'
+ # 'python-pep8-naming'
+ )
source=('git+https://github.com/vheon/JediHTTP'
'setup.py'
'allow-missing-vendor.patch')
@@ -38,8 +47,8 @@ prepare() {
check() {
cd "${srcdir}/JediHTTP"
- tox -e py27 --sitepackages
- tox -e py36 --sitepackages
+ tox -vv -e py27 --sitepackages
+ tox -vv -e py36 --sitepackages
}
package_python-jedihttp-git() {