summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarius Lindvall2020-04-01 16:51:30 +0200
committerMarius Lindvall2020-04-01 16:51:30 +0200
commitf58d49f0c133b0b263ed1f97c90eece07bfc7b17 (patch)
treeb3972f5913b72261b20837aba6d53635227d8601
downloadaur-f58d49f0c133b0b263ed1f97c90eece07bfc7b17.tar.gz
Initial version
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD23
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d0e192abde02
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-jellyfin-apiclient
+ pkgdesc = Python API client for Jellyfin
+ pkgver = 1.5.0
+ pkgrel = 1
+ url = https://github.com/iwalton3/jellyfin-apiclient-python
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ depends = python>=3.6
+ depends = python-requests
+ depends = python-urllib3
+ depends = python-websocket-client
+ depends = python-six
+ source = https://pypi.python.org/packages/source/j/jellyfin-apiclient-python/jellyfin-apiclient-python-1.5.0.tar.gz
+ sha256sums = e71080f44e601e31d1f439ef3f4281286f98e98f650f324df8446d14b5b7e170
+
+pkgname = python-jellyfin-apiclient
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aa4696f29d36
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Marius Lindvall <(firstname) {cat} varden {dog} info>
+
+pkgname=python-jellyfin-apiclient
+pkgver='1.5.0'
+pkgrel=1
+pkgdesc="Python API client for Jellyfin"
+arch=('any')
+url='https://github.com/iwalton3/jellyfin-apiclient-python'
+license=('GPL3')
+depends=('python>=3.6' 'python-requests' 'python-urllib3' 'python-websocket-client' 'python-six')
+makedepends=('python-setuptools')
+source=("https://pypi.python.org/packages/source/j/jellyfin-apiclient-python/jellyfin-apiclient-python-$pkgver.tar.gz")
+sha256sums=('e71080f44e601e31d1f439ef3f4281286f98e98f650f324df8446d14b5b7e170')
+
+build() {
+ cd "${srcdir}/jellyfin-apiclient-python-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/jellyfin-apiclient-python-${pkgver}"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}