summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Wright2022-04-12 14:37:07 +0100
committerJonathan Wright2022-04-12 14:37:07 +0100
commita8a74f08c457c3a4b61e2fe0b81050dcf349b629 (patch)
tree467c4d8d4dbf051a038e2381677790748b7bf8cb
parent43786174722f57711e51fde021058c015ef2c1bc (diff)
downloadaur-a8a74f08c457c3a4b61e2fe0b81050dcf349b629.tar.gz
Add sed command to remove <6 requirement for PyYAML
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD3
2 files changed, 3 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 78fd9a006aec..d73e2e9ca25b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-jenkins-job-builder
pkgdesc = Takes simple descriptions of Jenkins jobs in YAML or JSON format and uses them to configure Jenkins
pkgver = 3.12.0
- pkgrel = 2
+ pkgrel = 3
url = https://jenkins-job-builder.readthedocs.io/en/latest/
arch = any
license = APACHE
diff --git a/PKGBUILD b/PKGBUILD
index 38b44d5def4e..e21a6bce66a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_pkgname=jenkins-job-builder
pkgname=python-$_pkgname
pkgver=3.12.0
-pkgrel=2
+pkgrel=3
pkgdesc='Takes simple descriptions of Jenkins jobs in YAML or JSON format and uses them to configure Jenkins'
url='https://jenkins-job-builder.readthedocs.io/en/latest/'
license=('APACHE')
@@ -26,6 +26,7 @@ sha256sums=('829b28b782d6d4805f62df1e6fbd9626a33358400cb7882a58e0f52a14d08ddb')
build() {
cd "$srcdir/$_pkgname-$pkgver"
+ sed -e 's/^PyYAML\(.*\),<6 \(.*\)$/PyYAML\1 \2/' requirements.txt
python setup.py build
}