summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Wright2019-10-20 15:21:41 +0100
committerJonathan Wright2019-10-20 15:21:41 +0100
commitbcbd82f995851b0e67712c6a50b141836b2678dd (patch)
tree5ca32c813df8d370b3a01531c815728ad9d2133c
parentcddb3b74a93d244565d1c1afbadfa42165f4d62f (diff)
downloadaur-bcbd82f995851b0e67712c6a50b141836b2678dd.tar.gz
Bump package to 3.0.2-1
The package now requires additional dependencies (given the jump from 1.6.2 to 3.0.2) which have been included in the manifest. Also updated some links and paths as required.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD18
2 files changed, 22 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 776e5547000c..9036aec2db09 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,20 @@
-# Generated by mksrcinfo v8
-# Mon Apr 10 22:08:05 UTC 2017
pkgbase = python-jenkins-job-builder
pkgdesc = Takes simple descriptions of Jenkins jobs in YAML or JSON format and uses them to configure Jenkins
- pkgver = 1.6.2
+ pkgver = 3.0.2
pkgrel = 1
- url = http://docs.openstack.org/infra/system-config/jjb.html
+ url = https://docs.openstack.org/infra/jenkins-job-builder/
arch = any
license = APACHE
makedepends = python-setuptools
+ depends = python-six
depends = python-yaml
+ depends = python-pbr
+ depends = python-stevedore
depends = python-python-jenkins
- source = https://pypi.io/packages/source/j/jenkins-job-builder/jenkins-job-builder-1.6.2.tar.gz
- md5sums = 27877cd4ec3dada51a97442c23fa5f21
+ depends = python-fasteners
+ depends = python-jinja
+ source = https://files.pythonhosted.org/packages/2e/fb/b78fa65fe61e8d7b92864fa1b760f0451ba88fcebc899be85a41ca758019/jenkins-job-builder-3.0.2.tar.gz
+ sha512sums = 1110fa2fea327ae0a9ed346de2fab61b6623f9f2743996e599025a68e3b8294eef024c4d6dd300b1d6d37f7f98a5d763b8ae478cc3bedbc2e1a04359a0ba7254
pkgname = python-jenkins-job-builder
diff --git a/PKGBUILD b/PKGBUILD
index cccd30d51012..5f47ee1cf9fd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,26 @@
# Contributor: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Maxwell Pray a.k.a. Synthead <synthead@gmail.com>
+# Contributor: Jonathan Wright <jon@than.io>
_pkgname=jenkins-job-builder
pkgname=python-$_pkgname
-pkgver=1.6.2
+pkgver=3.0.2
pkgrel=1
pkgdesc='Takes simple descriptions of Jenkins jobs in YAML or JSON format and uses them to configure Jenkins'
-url='http://docs.openstack.org/infra/system-config/jjb.html'
+url='https://docs.openstack.org/infra/jenkins-job-builder/'
license=('APACHE')
arch=('any')
makedepends=('python-setuptools')
-depends=('python-yaml' 'python-python-jenkins')
-source=("https://pypi.io/packages/source/j/$_pkgname/$_pkgname-$pkgver.tar.gz")
-md5sums=('27877cd4ec3dada51a97442c23fa5f21')
+depends=(
+ 'python-six'
+ 'python-yaml'
+ 'python-pbr'
+ 'python-stevedore'
+ 'python-python-jenkins'
+ 'python-fasteners'
+ 'python-jinja')
+source=("https://files.pythonhosted.org/packages/2e/fb/b78fa65fe61e8d7b92864fa1b760f0451ba88fcebc899be85a41ca758019/${_pkgname}-${pkgver}.tar.gz")
+sha512sums=('1110fa2fea327ae0a9ed346de2fab61b6623f9f2743996e599025a68e3b8294eef024c4d6dd300b1d6d37f7f98a5d763b8ae478cc3bedbc2e1a04359a0ba7254')
build() {
cd "$srcdir/$_pkgname-$pkgver"