summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Wright2023-01-25 11:38:15 +0000
committerJonathan Wright2023-01-25 11:38:15 +0000
commitd08c467acdf39ea3d7af6cc126001c667e651500 (patch)
tree57f0a8fd8ff3554912cbfa18583a14684101bf3e
parent0798615d0bf9655d6b4edce57614ea9c40656723 (diff)
downloadaur-d08c467acdf39ea3d7af6cc126001c667e651500.tar.gz
Bump package to 4.1.0-1
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore4
-rw-r--r--Makefile83
-rw-r--r--PKGBUILD6
4 files changed, 93 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6a8e97911598..49db3cd9cae6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-jenkins-job-builder
pkgdesc = Takes simple descriptions of Jenkins jobs in YAML or JSON format and uses them to configure Jenkins
- pkgver = 3.12.0
+ pkgver = 4.1.0
pkgrel = 4
url = https://jenkins-job-builder.readthedocs.io/en/latest/
arch = any
@@ -13,7 +13,7 @@ pkgbase = python-jenkins-job-builder
depends = python-python-jenkins>=0.4.15
depends = python-fasteners
depends = python-jinja>=2
- source = https://files.pythonhosted.org/packages/c5/6d/616c26d403cf7cddaabcfe241aa8770fb217b263243ad8350b0152848168/jenkins-job-builder-3.12.0.tar.gz
- sha256sums = 829b28b782d6d4805f62df1e6fbd9626a33358400cb7882a58e0f52a14d08ddb
+ source = https://files.pythonhosted.org/packages/45/9b/bf0f284d27fd41707d849126b5bac29a1a02919304372a334ed869613318/jenkins-job-builder-4.1.0.tar.gz
+ sha256sums = e630a5b5da260f8bb92d9ad824550707fb0b3915d8b96a1e24e6a501c8b4f974
pkgname = python-jenkins-job-builder
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9d5904f00e83
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+jenkins-job-builder-*.tar.gz
+python-jenkins-job-builder-*.pkg.tar.zst
+pkg/
+src/
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..b4be89d4b289
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,83 @@
+MAKEFLAGS += --warn-undefined-variables
+SHELL := bash
+.SHELLFLAGS := -eu -o pipefail -c
+.DEFAULT_GOAL := push
+.ONESHELL:
+
+# Simple ANSI colours
+CC_YELLOW=\033[0;33m
+CC_WHITE=\033[1;37m
+CC_END=\033[0m
+
+# Get the version information
+current_pkgver=$(shell cat PKGBUILD | awk -F = '/^pkgver/ { print $$2 }')
+use_pkgver=$(current_pkgver)
+current_pkgrel=$(shell cat PKGBUILD | awk -F = '/^pkgrel/ { print $$2 }')
+use_pkgrel=$(current_pkgrel)
+
+ifneq ($(strip $(pkgver)),)
+ use_pkgver=$(pkgver)
+endif
+
+ifdef ($(string $(pkgrel)),)
+ use_pkgrel=$(pkgrel)
+else
+ ifeq ($(pkgver),$(current_pkgver))
+ use_pkgrel=$(shell expr $(current_pkgrel) + 1)
+ else
+ use_pkgrel=1
+ endif
+endif
+
+.PHONY: help
+help: ## Show this help message
+ @grep '.*:.*##' Makefile | grep -v grep | sort | sed 's/:.* ##/:/g' | column -t -s :
+
+.PHONY: clean
+clean: ## Clean the current workspace
+ @echo -e "${CC_YELLOW}==>${CC_WHITE} Cleaning up old package files${CC_END}"
+ rm -rf *.pkg.tar.{xz,zst} *.{zip,gz,xz,zst}{,.part}
+ @echo -e "${CC_YELLOW}==>${CC_WHITE} Cleaning up old working directories${CC_END}"
+ rm -rf ./pkg ./src
+
+.PHONY: pull
+pull: clean ## Pull changes from the AUR
+ @echo -e "${CC_YELLOW}==>${CC_WHITE} Check for, and pull, changes from AUR${CC_END}"
+ git pull --ff-only
+
+.PHONY: update-version
+update-version: pull ## Update the package version in PKGBUILD (use pkgver and pkgrel)
+ @echo -e "${CC_YELLOW}==>${CC_WHITE} Update the package to $(use_pkgver)-$(use_pkgrel)"
+ sed -i -e 's/^pkgver=.*$$/pkgver=$(use_pkgver)/' -e 's/^pkgrel=.*$$/pkgrel=$(use_pkgrel)/' PKGBUILD
+
+.PHONY: update-pkgbuild
+update-pkgbuild: update-version ## Update the checksums in the PKGBUILD
+ @echo -e "${CC_YELLOW}==>${CC_WHITE} Update the checksums in PKGBUILD${CC_END}"
+ updpkgsums
+
+.PHONY: build
+build: ## Build the package (as a test)
+ @echo -e "${CC_YELLOW}==>${CC_WHITE} Build the package as a test${CC_END}"
+ makepkg -s
+
+.PHONY: update-srcinfo
+update-srcinfo: update-pkgbuild build ## Update the .SRCINFO file
+ @echo -e "${CC_YELLOW}==>${CC_WHITE} Update the .SRCINFO file${CC_END}"
+ makepkg --printsrcinfo > .SRCINFO
+
+.PHONY: commit
+commit: update-pkgbuild update-srcinfo ## Commit the changes to the repository
+ @echo -e "${CC_YELLOW}==>${CC_WHITE} Commit the PKGBUILD and .SRCINFO files${CC_END}"
+ git add PKGBUILD .SRCINFO
+ git commit -m "Bump package to $$(
+ cat .SRCINFO \
+ | awk -F ' = ' \
+ ' /\s+pkgver/ { version=$$2 }
+ /\s+pkgrel/ { release=$$2 }
+ END { printf "%s-%s", version, release }'
+ )"
+
+.PHONY: push
+push: commit ## Push the changes back to up the AUR
+ @echo -e "${CC_YELLOW}==>${CC_WHITE} Push the changes up to the AUR${CC_END}"
+ git push
diff --git a/PKGBUILD b/PKGBUILD
index 50cef26963b2..423074bd9342 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname=jenkins-job-builder
pkgname=python-$_pkgname
-pkgver=3.12.0
+pkgver=4.1.0
pkgrel=4
pkgdesc='Takes simple descriptions of Jenkins jobs in YAML or JSON format and uses them to configure Jenkins'
url='https://jenkins-job-builder.readthedocs.io/en/latest/'
@@ -21,8 +21,8 @@ depends=(
'python-python-jenkins>=0.4.15'
'python-fasteners'
'python-jinja>=2')
-source=('https://files.pythonhosted.org/packages/c5/6d/616c26d403cf7cddaabcfe241aa8770fb217b263243ad8350b0152848168/jenkins-job-builder-3.12.0.tar.gz')
-sha256sums=('829b28b782d6d4805f62df1e6fbd9626a33358400cb7882a58e0f52a14d08ddb')
+source=('https://files.pythonhosted.org/packages/45/9b/bf0f284d27fd41707d849126b5bac29a1a02919304372a334ed869613318/jenkins-job-builder-4.1.0.tar.gz')
+sha256sums=('e630a5b5da260f8bb92d9ad824550707fb0b3915d8b96a1e24e6a501c8b4f974')
build() {
cd "$srcdir/$_pkgname-$pkgver"