summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAustin Keller2020-04-21 15:00:00 -0700
committerAustin Keller2020-04-21 17:20:48 -0700
commita14d4330982a7330fcb31c670ffafdf09a19e27f (patch)
tree07ba8e67202de831c67b47f1e12b0a915fee7f50
downloadaur-a14d4330982a7330fcb31c670ffafdf09a19e27f.tar.gz
initial commit, jep version 3.9.0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..01202985d010
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-jep
+ pkgdesc = Java Embedded Python - Embeds CPython in Java through JNI
+ pkgver = 3.9.0
+ pkgrel = 1
+ url = https://github.com/ninia/jep
+ arch = any
+ license = ZLIB
+ makedepends = python-setuptools
+ depends = python-setuptools
+ depends = python-numpy
+ source = https://files.pythonhosted.org/packages/5c/4c/ab6253ba5409ee787604dcbf1b02733aeed03ce0cf7d85a9ab5cfd4956b2/jep-3.9.0.tar.gz
+ sha256sums = 7a15b6279b703c8af6b1f002186c542770f9059e8b3fe724914f664e67b7e595
+
+pkgname = python-jep
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5aae4561cdd5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Austin Keller <austin474@gmail.com>
+
+pkgname=python-jep
+pkgver=3.9.0
+pkgrel=1
+pkgdesc="Java Embedded Python - Embeds CPython in Java through JNI"
+arch=('any')
+url="https://github.com/ninia/jep"
+license=('ZLIB')
+depends=('python-setuptools' 'python-numpy')
+makedepends=('python-setuptools')
+source=(https://files.pythonhosted.org/packages/5c/4c/ab6253ba5409ee787604dcbf1b02733aeed03ce0cf7d85a9ab5cfd4956b2/jep-$pkgver.tar.gz)
+sha256sums=('7a15b6279b703c8af6b1f002186c542770f9059e8b3fe724914f664e67b7e595')
+
+build() {
+ cd jep-$pkgver
+ python3 setup.py build
+}
+
+check() {
+ cd jep-$pkgver
+ python3 setup.py test
+}
+
+package() {
+ cd jep-$pkgver
+ python3 setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+}